[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Cannot mount floppy drive in Squeeze

Stephen Powell wrote:
>    mount -t msdos /dev/fd1 /media/floppy1
> ...
> It tells me that /media/floppy1 is not mounted!  When I try to read the data
> directly with
>    dd if=/dev/fd1 of=erase.me count=1
> It successfully reads the boot sector into the file erase.me; so the
> drive and the disk itself seem to be OK.

Since you can read the disk try reading the entirety of the floppy
over to your filesystem.  Then try mounting the resulting file using
the loopback device.

  mount -o loop,ro /path/to/floppy-image /media/floppy1

Perhaps that will give a clue.

> I tried other disks and also tried 3.5-inch disks in the other
> floppy drive, but I can't seem to get any floppy disk to mount.  Am
> I doing something wrong?  Or is there a bug here?

As an alternative try the 'mtools' on it.  It accesses the data
without mounting.

  Description: Tools for manipulating MSDOS files
   Mtools is a collection of utilities to access MS-DOS disks from Unix
   without mounting them. It supports Win'95 style long file names, OS/2
   Xdf disks, ZIP/JAZ disks and 2m disks (store up to 1992kB on a high
   density 3 1/2 disk).

The you could try something like "mdir a:" and similarly.  I am not
suggesting this is better (or worse) but just different and may
produce different output which may provide clues.

I suspect that the data on the floppy is corrupted.  But you will need
more digging to find out the root cause.

You might try taking a different floppy and try formatting it.

  mkfs -t msdos /dev/fd1


Attachment: signature.asc
Description: Digital signature

Reply to: