[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Cannot mount floppy drive in Squeeze

Well, I'm not exactly a newbie.  I've been using Linux for more than 10 years.
But I must be doing something wrong.  I can't seem to get a floppy disk to

My i386 system has a standard floppy disk controller with two floppy drives:
a 3.5-inch high density drive (1.44M in DOS format) and a 5.25-inch high
density drive (1.2M in DOS format).  I'm trying to mount a double-sided,
double density 5.25-inch floppy disk (360K in DOS format) in
the 5.25-inch high density drive.  I am running the latest Debian Squeeze.
As root, I issue the command:

   mount -t msdos /dev/fd1 /media/floppy1

I receive a warning message

   FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!

but I'm used to that.  That's just a warning.  But when I then issue


with no operands, it does not show the floppy as mounted.  And when I try to
unmount it with

   umount /media/floppy1

It tells me that /media/floppy1 is not mounted!  When I try to read the data
directly with

   dd if=/dev/fd1 of=erase.me count=1

It successfully reads the boot sector into the file erase.me; so the drive and
the disk itself seem to be OK.  I tried other disks and also tried 3.5-inch
disks in the other floppy drive, but I can't seem to get any floppy disk
to mount.  Am I doing something wrong?  Or is there a bug here?  I am running
stock Debian kernel 2.6.32-5-686 version 2.6.32-28.

  .''`.     Stephen Powell    
 : :'  :
 `. `'`

Reply to: