[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unable to load the kernel module 'nvidia.ko' in 2.6.32-5-686 kernel

On Sunday 18 July 2010 01:22:00 Jason Filippou wrote:
> Hello list,
> I just installed the new 2.6.32-5-686 kernel and I've been having
> trouble installing the NVIDIA linux display driver. Usually this
> process required of me only to download the linux-headers for the
> relevant kernel release and then running the shell script provided by
> NVIDIA on their website. I tried doing this with the 190.53 driver,
> which is an old driver that worked perfectly for me, and the newest
> 256.35 driver provided by NVIDIA. In both cases, I get the ordinary
> message about the CC check that failed because the gcc version that
> was used to compile my kernel was not the same as the one used to
> compile the driver and I also see the "compiling kernel module"
> progress bar filling up to 100%. After this, I get the following
> message:
> "Unable to load the kernel module 'nvidia.ko'. This happens most
> frequently when this kernel module was build against the wrong or
> improperly configured kernel sources, with a version of gcc that
> differs from the one used to build the target kernel, or if a driver
> such as rivafb/nvidiafb is present apd prevents the NVIDIA kernel
> module from obtaining ownership of the NVIDIA graphics device(s), or
> NVIDIA GPU installed in this system is not supported by the NVIDIA
> LINUX graphics driver release."
> And after that I'm suggested to check some log files. My gcc version is:
> jason@debian:~$ gcc -v | grep version
> gcc version 4.4.4 (Debian 4.4.4-6)
> I googled a bit and the most complete solution to the problem that I
> found was manny's response to this thread:
> http://forums.debian.net/viewtopic.php?f=7&t=2797
> Yet my problem's still not been solved. I've also installed the proper
> linux-headers package, as can be verified through aptitude:
> jason@debian:~$ sudo aptitude show linux-headers-2.6.32-5-686
> [sudo] password for root:
> Package: linux-headers-2.6.32-5-686
> New: yes
> State: installed
> Automatically installed: yes
> Version: 2.6.32-15
> Priority: optional
> Section: kernel
> Maintainer: Debian Kernel Team <debian-kernel@lists.debian.org>
> Uncompressed Size: 6,885k
> Depends: linux-headers-2.6.32-5-common (= 2.6.32-15),
> linux-kbuild-2.6.32, gcc-4.3
> Provides: linux-headers, linux-headers-2.6
> Description: Header files for Linux 2.6.32-5-686
>  This package provides the architecture-specific kernel header files
> for Linux kernel 2.6.32-5-686, generally used for building out-of-tree
> kernel modules.  These files are going
>  to be installed into /usr/src/linux-headers-2.6.32-5-686, and can be
> used for building modules that load into the kernel provided by the
> linux-image-2.6.32-5-686 package.
> Which steps should I follow to compile the NVIDIA driver into the new
> kernel?
> Thanks for your time.

to make it work with the stuff from Nvidia's site,

1. Squeeze kernel 2.6.32-5 is configured with gcc 4.3.5
2. gcc that is installed on Squeeze is 4.4.4 & 4.3.5
3. installing gcc creates a  symbolic link to  version of gcc-4.4.4
4. gcc is a depend of a few packages, dkms for one, but is not installed by 
default, or as a depend of the kernel or matching headers.

I had to create the symlink : 'ln -s /usr/bin/gcc-4.3  /usr/bin/gcc'

'cat /proc/version' shows the version of gcc that was used
'gcc -v' shows what version of gcc is being used.

btw, is this a bug ? 



Reply to: