[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Re: Password messed up

  Coming in late to this thread, but if your K desktop is OK,
then you actually have this problem quite well isolated to something
in the KDM log-in process. It's not X, and it's not your desktop

  By the time KDM has switched over to you, it's writing errors
into a file, ".xession-errors", in your home directory -- you can
check this for clues to what's going on.

  Another option is to blitz kdm's config files, and re-configure
or re-install the package. I'm not familiar with how sid does this, but you can do "dpkg -L kdm", and look for files in
the /etc directory -- for the current Debian stable it's
/etc/kde3/kdm.  I suggest re-naming the analogous directory
(don't delete it, you might want it back), and then doing
"apt-get install --reinstall kdm", or whatever the analogous
operation is in aptitude or synaptic, if that's your preference,
which should re-build the configuration section.  That's likely
to fix it, at the cost of un-doing any customizations you've

  If blitzing and re-building the kdm config fails, then it's
probably some kind of interaction between kdm and something else...

				-- A.
Andrew Reid / reidac@bellatlantic.net

Hi Andrew,

Thanks for jumping in here.  I've tried the following:

1. I have no ".xsession-errors" (or ".xession-errors") in my home directory or that of any other user.

2. It appears the configuration files for kde4 are found under "/usr/share/kde4/config" and also "/etc/kde4/kdm/". I tried moving the "config" directory to an obscure location and the doing the "apt-get install --reinstall kdm". It regenerated the config directory but no change in login.

3. I found that under /user/bin (when doing the dpkg -L kdm) there is a file "genkdmconf" which looked promising. Reading the help file for it and executing "genkdmconf -no-old", the files under /etc/kde4/kdm were backed up and new ones regenerated. Now, I get a different login screen background, but the action is still the same -- does not accept my password. I can still use the "console login" option of that screen and get to the CLI login and doing so still allows me to startx and get things going.

So it appears that your last paragraph applies. I'll be glad to try (almost) anything you or anyone else suggests on this.

(I am also, per my previous message, starting another thread for the symbol not found problem I have in trying to get some applications running (synaptic, iceape, geany to name a few).)


Reply to: