[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: GRUB2 == Non Bootable System

Hendrik Boom wrote:
On Thu, 01 Apr 2010 19:58:56 -0700, briand wrote:

On Thu, 1 Apr 2010 17:46:49 -0700
Scarletdown <scarletdown@gmail.com> wrote:

I just did a fresh very basic Debian Sid install on my "experimental"
system (one hard drive with only a single partition), basic install
meaning console only and just the following packages: ssh, mc, samba,
elinks, sudo, and ClamAV.

After all the packages were installed, I ran apt-get dist-upgrade. This
replaced GRUB 1.5 with GRUB 2. A reboot showed no problems, so I then
gave the upgrade-from-grub-legacy command followed by the removal of
the old unused /boot/grub/menu.lst just as the upgrade suggested.

A reboot now gives me:

GRUB Read Error
Operating system not found

I had this problem not too long ago and the recovery was relatively
painful.  You basically have to boot into rescue, download the
appropriate packages and then re-install either grub or lilo.  I highly
recommend lilo.

There is a web-page somewhere that goes through this in detail - I'm
sorry but I just can't seem to find it.

I'm relatively certain I found the link to it somewhere in the debian
bugs for one of the grub packages.


I make sure I can always boot from a floppy disk -- usually one I've told lilo to boot from when I ran lilo -v. This is quite independent of grub.

But too late for you, now.

There's also the Super Grub Boot Disk, which you can download from somewhere and copy to a floppy. I think it contains all the grub things you need to boot (the ones it usually gets from wherever they hide out on your hard drive), and it's possible to edit its menu.list that's also on it.

I prefer Super Grub Disk to both legacy grub and grub2 because you don't have to hardcode anything anymore, like

root            (hd0,5)

but you can use variables to describe the root, like:

title           linux-image-2.6.32-3-686 HDB3 from do_apt-get (03/11/10)
findf           /ST380011A.03
root            $(out_device)
kernel /boot/vmlinuz-2.6.32-3-686 root=LABEL=ST380011A.03 noapic apm=on vga=791 edd=off ddcon-1 acpi_en
force_resources=lax network quiet
initrd          /boot/initrd.img-2.6.32-3-686

That means that he finds file ST380011A.03 on any disk in any partition and the partition and disk where he finds it, *that* is the root partition.

SGD has both CD's and floppies. I prefer the CD's. The most recent version suppoorts grub2.


Reply to: