[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: wicd fails to start after upgrade

On Fri, Jan 29, 2010 at 02:36PM -0500, Wayne <linuxtwo@gmail.com> wrote:

> >>Sebastian wrote:
> >>>After the last upgrade wicd fails to start. It also stopped writing it's logs and when I call it directly by just entering 'wicd' I get following error:
> >>>
> >>>Traceback (most recent call last):
> >>>  File "/usr/share/wicd/daemon/wicd-daemon.py", line 61, in <module>
> >>>    from wicd.logfile import ManagedStdio
> >>>ImportError: No module named logfile
> >>>
> >>>I tried purging and re-installing it but to no avail...
> >>>Should I file this as a bug or is it just me not seeing something obvious?
> >
> >I'm running squeeze/sid (apt prefers testing) mainly testing yet I am
> >a bit confused as I can only seem to find version 1.7.0-2 of wicd on
> >my system but packages.debian.org states that the current testing
> >version is and testing is 1.7.0-2 (my version). I tried
> >removing it and re-installing with 'apt-get install wicd='
> >with the reply: E: Version '' for 'wicd' was not found?!?
> I also run testing/sid and my wicd is from testing.
> >Even if I remove the unstable and stable entries from sources.list and
> >apt/preferences no other versions show up
> I would not put all 3 dists in sources.list.  That could/would cause
> quite some mess.  testing/unstable is bad enough but you should be
> careful using it.  If I even 'think' about pulling in an unstable
> package, and it's dependices,  [...snip...]

I thought if you set up apt-pinning in /etc/apt/preferences that
should be possible without any major problems?

>   [...snip...]
>  I first run apt-listbugs on all of
> those packages before I download any of them

Yes, I have apt-listbugs installed and working here as well, yet I
can't remember any bugs for wicd coming up before the upgrade - of
course it was late in the night and who knows what I was seeing ;-)

Anyway, I removed unstable from the sources.list and tried removing
and re-installing wicd but I can still only get 1.7.0-2

> Yes 'apt-cache policy wicd' will show the packages in every dist you
> have in the sources.list, I believe. Here it shows both
> testing/unstable.

thanks, 'apt-cache policy wicd' shows
  Installed: 1.7.0-2
  Candidate: 1.7.0-2
  Version table:
 *** 1.7.0-2 0
        700 http://ftp.ie.debian.org testing/main Packages
        100 /var/lib/dpkg/status

hmmm... 1.7.0-2 is testing??? And no 1.6...?
Getting more and more confused here... - Any hints?

> Hope this helps
> Wayne

Thanx a mil Wayne


A man of genius makes no mistakes.
His errors are volitional and are the portals of discovery.
		-- James Joyce, "Ulysses"

Reply to: