[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: serious problems with mutt

Camaleón wrote:
On Sat, 02 Jan 2010 16:32:28 +0100, Bernard wrote:

But, with my 3 months old Lenny system on my desktop, I can't get mutt
to work !  Here, I have to use 'exim4', and I have spent many hours
turning around dpkg-reconfiguring exim4-config so many times. I surely
carried close to 100 different tests, since there are so many options to
choose from. What confuses me most is that it does occasionnally seem to
work once or twice, and then I can't reproduce the success.

The problem lies in sending mail, no problem receiving.

No need to use external "esmtp" or "Exim" mail server with Mutt. It comes compiled with "+USE_SMTP" flag on so if you are using just one e-mail account, you can configure Mutt itself to send the e-mails directly to your ISP host.

That is the way I use it with my Gmail account.


I am not sure if my mutt version came compiled with "+USE_SMTP" : how shall I make sure of this ? In any case, I've just tried disabling my ~/.muttrc conf file, which was copied from my old sarge system, and contained the following lines :

# set sendmail="/usr/bin/esmtp -X /tmp/esmtp.log"
# set sendmail="/usr/lib/sendmail -oi -oem"
set sendmail="/usr/sbin/exim4"

Once this file removed (it didn't contain much more than that, nothing that seemed important to me), the default /etc/Muttrc conffile is being used. I then tried to use mutt this way. Receiving mail did seem to work, but no way to send anything. In the end of the sending process, it says : "sent", but nothing gets to destination, and I don't know where to look for logfiles. By the way, this last test showed that my call to

set sendmail="/usr/sbin/exim4"

which was asked by former .muttrc file, was indeed taken into account, since I used to get error messages in my local mailbox when trying to send to external domains while exim4-config was set to local mail only, which error msg I don't get anymore. Nothing appears any longer in /var/log/exim4/mainlog, except that retrying of onqueued old failed tests is still endlessly going on : how should I stop this ?

By the way, I have just also tried re-activating my .muttrc file, unquoting alternately # set sendmail="/usr/lib/sendmail -oi -oem", and then, for another test : # set sendmail="/usr/bin/esmtp -X /tmp/esmtp.log". First test gave same result as described above, that is, no error message, but nothing arrives. Second test sent the following message where I expected "sent" : "error sending msg. Thread ended with code 127, Exec error"

Maybe I should try to install esmtp, as it is on my laptop on Ubuntu Hardy Heron... But I've heard so much about exim4 being so much better, safer and more versatile, that I might give it some more effort.

Reply to: