[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

serious problems with mutt


I have made a very light use of mutt for several years, for special purposes only. So I can't say that I am very familiar with it. On my old systems (RedHat 7.2) it was based on sendmail for sending mail. Then, on Debian Sarge, it used 'esmtp'. I spent some time to find the right config, fetching pipes here and there. Now, on my laptop running Ubuntu 8.04 (Hardy Heron), my mutt is still using esmtp. And it seems to operate all right.

But, with my 3 months old Lenny system on my desktop, I can't get mutt to work ! Here, I have to use 'exim4', and I have spent many hours turning around dpkg-reconfiguring exim4-config so many times. I surely carried close to 100 different tests, since there are so many options to choose from. What confuses me most is that it does occasionnally seem to work once or twice, and then I can't reproduce the success.

The problem lies in sending mail, no problem receiving.

I understand that you can choose between one single config file and a set of various files. In the dpkg-reconfigure process, I have chosen one only conf file. I suppose that this is the one :


This is a very short file, and it contains the informations that I have specified during dpkg-reconfiguring. The uncommented lines are as follows :

dc_other_hostnames='orange.fr ; free.fr ; teaser.fr'

At one time (yesterday some time), I have been able to send mail to remote addresses using "smtp.teaser.fr::587". It no longer works, but I changed parameters so many times that I can't remember exactly in what config scheme it did work (what a shame !). When that did work, I next tried sending through smtp.free.fr (with no channel number, since it uses default = 25). Nothing worked with 'smtp.free.fr'. /var/log/exim4/mainlog says : "unrouteable address". Next, I realized that smtp.free.fr requires a login and pswd. So does smtp.teaser.fr, which however has worked without login and pswd, which possible reason may be that pswd had already been sent during previous use with Thunderbird. So, I tried to enter login and pswd for smtp.free.fr :

in /etc/exim4, I found a file that is named 'passwd.client'. I edited it and introduced login and pswd, but this did not seem to change anything ; I wonder if that file is even taken into account. In any case, where should I find debug info about login and pswd ?

If anyone wishes to see the results of my two latter tests, this is available in a rtf file from


Thanks in advance for your help.

Reply to: