[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: install -- netboot vs netinst vs businesscard Debian installer CDs

On 2010-01-01 at 23:45:08 -0500, Rick Thomas wrote:
> I'm pretty sure it was not the lenny installer.  I installed in  
> "expert" mode and it offered a menu to let me install stable, testing,  
> or unstable.  This is something that the lenny installer doesn't do,  
> if I'm not mistaken.

I'm going from memory here; but if I recall correctly, which releases it
lets you install depends on which "Release" files it finds on the Debian
mirror you point it to, for a netinst or netboot install.  It doesn't
necessarily mean that the installer you are using will work for the
release you are trying to install.  For example, I earlier attempted
to install Squeeze using the Lenny installer (although I didn't know
at the time that it was the Lenny installer).  I also installed in
expert mode, and it gave me a choice of which releases I wanted to install.
I chose Squeeze (testing).  It mostly worked, except when it came time
to install the boot loader.  Installation of grub failed, and I had to
install lilo instead.  That's because Lenny uses grub (what Squeeze calls
grug-legacy) and Squeeze uses grub (what Lenny calls grub2).  The Lenny
installer tried to use grub1 methods to install grub2 and it did not work.
It also installed some packages (such as console-tools on the i386
architecture) which are deprecated, and which the Squeeze installer
presumably wouldn't have installed.

> In any case, I got the iso from this URL:
>    http://http.us.debian.org/debian/dists/sid/main/installer-powerpc/current/images/powerpc/netboot/
> And the particular iso I downloaded was:
>    Index of /debian/dists/sid/main/installer-powerpc/current/images/ 
> powerpc/netboot
>    [ ]	mini.iso	17-Dec-2009 05:34 	13M
>    Apache/2.2.9 (Debian) Server at http.us.debian.org Port 80

I forgot to check Sid.  I saw that the Squeeze installer was a duplicate of
the Lenny installer, but I forgot to check Sid.  It does appear that this
installer is newer than the Lenny installer, and might work correctly to
install Squeeze.

> I don't know why the date is 17-Dec-2009, not something more recent.
> Maybe that's why it worked?  More recent ones are broken?
> I'm fairly sure it ran the Sid d-i.  It's behavior was identical to  
> the behavior
> of the "businesscard" install CD from this URL:
>    http://cdimage.debian.org/cdimage/daily-builds/sid_d-i/arch-latest/powerpc/iso-cd/
> when the businesscard install works (which it doesn't, right now...)

They've had some build issues in the last several weeks.  See the debian-cd
mailing list archive for discussions on these build issues.  It seems to
me that the graphical installer, or lack thereof, was the cause of the
build issues somehow.  Let's hope that they get this straightened out soon!

Reply to: