[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [Fwd: Re: Alt key not working]



On Wed, Dec 09, 2009 at 04:49:29PM EST, roberto wrote:
> On Wed, Dec 9, 2009 at 10:40 PM, Andrew Sackville-West
> <andrew@farwestbilliards.com> wrote:
> >> well, running showkey as root from vt1 gives me:
> >> 0x64 0xe4
> >>
> >> so the kernel recognizes the key but anyway it does not work under X
> >> (kdm is the manager for kde 3.5)
> >
> > now try xev in an xterm and see what output you get for the alt key.
> >
> 
> i get the following output:
> 
> KeyPress event, serial 31, synthetic NO, window 0x4c00001,
>     root 0x58, subw 0x0, time 167180255, (332,-16), root:(336,306),
>     state 0x0, keycode 113 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
>     XLookupString gives 0 bytes:
>     XmbLookupString gives 0 bytes:
>     XFilterEvent returns: False
> 
> KeyRelease event, serial 34, synthetic NO, window 0x4c00001,
>     root 0x58, subw 0x0, time 167180340, (332,-16), root:(336,306),
>     state 0x80, keycode 113 (keysym 0xfe03, ISO_Level3_Shift), same_screen YES,
>     XLookupString gives 0 bytes:
>     XFilterEvent returns: False

Basically says that your Alt key is mapped to AltGr.

Try:

$ xmodmap -
keycode 113 = Alt_R
Ctrl+D¹

And check whether your Alt key is working again.

CJ

¹ Followed by a dash, xmodmap reads your commands form stdin. After
  remapping your Alt key, you need to hit the Control and the D keys
  simulataneously to tell xmodmap that you're done.


Reply to: