[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: What can I run on Stable?

On Mon, 30 Nov 2009 23:07:56 -0600
Kumar Appaiah <a.kumar@alumni.iitm.ac.in> wrote:

> On Mon, Nov 30, 2009 at 08:23:56PM -0800, John Jason Jordan wrote:
> [snip]
> > I absolutely require the following:
> > 
> > Gnome desktop (yes, I've tried all the others)
> This works fine in Lenny.

I have used Gnome on Ubuntu for four years and never had a significant problem.
But when I installed Testing it came with 2.8.1. After a few days of working
with it I rebooted. And when X came up I had lost the gnome-panel and metacity. 

Later I installed Fedora 12 (Gnome 2.8.0), and got bitten by the same bug. And
then I installed OpenSuse 11.2 (Gnome 2.8.0), and gotten bit once again by the
same bug.

In discussing this at length on this list, the Fedora forums, and the OpenSuse
forums, everyone wants me to file a bug report with Gnome. I'd be thrilled to
do so, except that I know the response will be "unable to reproduce." The
problem is that I cannot tell which if the literally hundreds of configuration
changes and installed apps, and combinations thereof, caused the problem.

However, I never had a problem with Gnome with any version of Ubuntu through
Jaunty so, as long as Lenny comes with a version no later than Jaunty, I should
be fine.

> > OpenOffice.org (fixes bugs in the Math module)
> It appears that Backports might help:
> http://tuxarena.blogspot.com/2009/08/how-to-install-openoffice-31-in-debian.html

It is not clear from that web site that it is possible to install on
Lenny. On the other hand, I know there is a 64-bit deb file on the OOo web site
that I can download. I could always wipe out the OOo that is installed by
default with Lenny and then install the OOo version. The problem with this is
that there are a lot of additional goodies that you don't get with the base
> > Scribus (I need the features)
> Even unstable has only; you might have to build this on your own.

Over four years of Ubuntu I have never built a package on my own. I hope I can
get instriuctions. And I dimly recall reading on the Scribus e-list that
Scribus requires some odd, different utility to compile it. But I'm borrowing
trouble. I should wait to complain after I have a problem.

> > Adobe Reader 9.1
> Debian Multimedia seems to have only Acrobat 8.1, but I'd think you
> can use Adobe's own distributed tarball/package?

That is easier said than done. I know that 9.1 is in the Ubuntu medibuntu
repos. Is it possible to add this repo?

> > Okular (any reasonably recent version)
> > praat (for speech analysis)

Good to hear they are in the repos.

> > support for my bluetooth mouse and headphones
> This, I believe, might be a kernel issue. I'd recommend using an
> up-to-date kernel with Lenny; that shouldn't be much of a problem with
> Lenny backports.

The GUI connects them without a hitch in Ubuntu, Fedora 12 and OpenSuse 11.2.
But when I ran Testing I could never get the mouse working. The GUI was utterly
broken. I never tried the headphones. Both work fine in OpenSuse, Fedora, and
Ubuntu. It was only in Testing where I could not get them working. And I tried
the command line as well, but hcitool didn't work either.

> > I apologize for sounding negative. The past ten days have been majorly
> > frustrating.
> I can sympathize with that; getting complex software, especially
> non-free ones, to work the way you want is not a simple task. I hope
> the information above is useful to you. Should you face any further
> issues with Lenny, do come to this list; I am sure people will help
> solve your problems to the best of their ability.

When I was struggling with Testing, and later with Unstable, this list has been
a godsend. Thanks for your input.

It is late at night and my bedtime. Tomorrow morning I will have a better
attitude. But I am considering that OpenSuse 11.1 is hopeless and needs to be
replaced, I think my next stop will be Fedora 11. Fedora 12 was a mess only
because it came with Gnome 2.8.0. Maybe Fedora 11 will work for me.

If Fedora 11 can't get me a working desktop computer, my next stop will be

Reply to: