[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Optical Dell Mouse - seems standard doesn't work on xorg

2009/10/27 Aioanei Rares <debian.dev.list@gmail.com>
Thomas Douillard wrote:
2009/10/27 Aioanei Rares <debian.dev.list@gmail.com <mailto:debian.dev.list@gmail.com>>

   Thomas Douillard wrote:

       Seems not to, and nothing happens if I "cat /dev/input/mice"
       and move the mouse. It is a usb mouse.

       I tried "gpm -m /dev/input/mice".
       2009/10/27 Aioanei Rares <debian.dev.list@gmail.com

          Thomas Douillard wrote:

              Hi, I've got a problem since an upgrade (I don't kwon since
              when unfortunately), my standard optical wheel mouse don't
              work anymore on X, on an debian SID

              I don't know who I must blame (hal, udev, the kernel, xorg
              ...) so I can't post a bugreport on the good package. I'll
              attach some logfiles, if anyone can help me or suggest
       a way
              to proceed ...

              I also filed a udevadm test, if it can help ...


          Thomas, does it work in console if you enable gpm?

   Just to be sure, did you try to plug it in another USB port? And
   when I said console, I meant enable gpm to start at boot, reboot,
   press alt+ctrl+Fx and see if it moves.

Yep, I did.

I also purged and reinstalled gpm, rebooted, checked the mouse in console, just to be sure also, it did not worked as expected (since cat /dev/input/mice don't do anything, and it is the device used by gpm by default)

I can add that I'm quite sure it is related to the model of the mouse : I tried with an identical mouse, it did'nt work, with a microsoft one therer was no problems.

It may be related with a similar issue on ubuntu : https://bugs.launchpad.net/ubuntu/+source/linux/+bug/378818 but may not : in this issue the keyboard (same model as me I think) did not work also, while mine works. The workaround I found on his computer to solve the problem on his computer did not work on mine : I added a mouse and keyboard section as old times in the xorg.conf file.

Well, it's not only a Xorg problem as long as you see it in the console. AFAICS from the Ubuntu bug, looks like a kernel problem, but since their kernel is different from ours, you might wanna try an (preferably older) kernel and if that works, report a bug.

I tried that just after the upgrade, and the symptoms where the same with the pre-upgrade kernel version at the time, so I suspect it's not really a kernel problem ... plus the dmeg's correctly recognize a HID device, as the dmesg attatched to my first mail shows ... I suspect bug in udev rules or a bug in hal, but since I don't really know how all this work ... I may post a bug in the udev package for a start ...

PS : I forgot to reply to the list, I copy paste the discussion, sorry for that ...

Reply to: