[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "aptitude safe-upgrade" in sid has several broken packages

Rick Thomas wrote:
Thanks for the suggestion...

But I think there's something I don't understand...

From the package descriptions, it sounds like the epiphany folks are headed in the direction of epiphany-browser and away from epiphany-webkit. Wouldn't installing epiphany-webkit be a step backwards?

I'm not sure. It seems you're right. Following informations from package descriptions:
$ aptitude show epiphany-browser
Package: epiphany-browser
New: yes
State: installed
Automatically installed: yes
Version: 2.28.0-4
Priority: optional
Conflicts: epiphany-extensions (< 2.22.1-3), epiphany-gecko, epiphany-webkit (<
Replaces: epiphany-gecko, epiphany-webkit (< 2.28)

$ aptitude show epiphany-webkit
Package: epiphany-webkit
New: yes
State: installed
Automatically installed: no
Version: 2.28.0-4
Priority: optional
Section: gnome
Maintainer: Josselin Mouette <joss@debian.org>
Uncompressed Size: 53.2k
Depends: epiphany-browser (>= 2.28.0)
Description: Dummy, transitional package
This package has been made obsolete by epiphany-browser 2.28.0, and is safe to
Homepage: http://www.gnome.org/projects/epiphany/

From descriptions above it's clear that you don't need epiphany-webkit anymore... I just made a test and system allowed me to remove epiphany-webkit with no problems amd dependencies.

Despite of information above it seems that installing epiphany-webkit with all dependencies soled the problem. Not sure what was the cause :/

Best regards,
Tomek Kruszona

Reply to: