[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: "aptitude safe-upgrade" in sid has several broken packages

On Oct 8, 2009, at 3:15 PM, Tomek Kruszona wrote:

Rick Thomas wrote:
The following packages are BROKEN:
 epiphany-browser epiphany-extensions-more libgnokii4 python-qt4


Regarding epiphany:
It seems has something in common with epiphany gecko to webkit transition. Try installing epiphany-webkit. It should remove obsolete packages and install epiphany with webkit support.

About rest of the problems I don't know :)

Best regards,
Tomek Kruszona

Thanks for the suggestion...

But I think there's something I don't understand...

From the package descriptions, it sounds like the epiphany folks are headed in the direction of epiphany-browser and away from epiphany- webkit. Wouldn't installing epiphany-webkit be a step backwards?


 $ aptitude show epiphany-webkit
Package: epiphany-webkit
State: not installed
Version: 2.28.0-4
Priority: optional
Section: gnome
Maintainer: Josselin Mouette <joss@debian.org>
Uncompressed Size: 53.2k
Depends: epiphany-browser (>= 2.28.0)
Description: Dummy, transitional package
This package has been made obsolete by epiphany-browser 2.28.0, and is safe to remove.
Homepage: http://www.gnome.org/projects/epiphany/

 $ aptitude show epiphany-browser
Package: epiphany-browser
State: installed
Automatically installed: no
Version: 2.26.3-2
Priority: optional
Section: gnome
Maintainer: Josselin Mouette <joss@debian.org>
Uncompressed Size: 32.8k
Depends: epiphany-gecko
Description: Intuitive web browser - dummy package
Epiphany is a simple yet powerful GNOME web browser targeted at non- technical users. Its principles are simplicity and
 standards compliance.

This dummy package installs Epiphany with the Gecko backend by default.
Homepage: http://www.gnome.org/projects/epiphany/

Reply to: