[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Grub 1.5 error after update

Hash: SHA1

On Mon, 21 Sep 2009 09:47:48 +0100
Joe <joe@jretrading.com> wrote:

> Frank wrote:
> >
> > During today's update on my testing machine I was asked whether I wanted to
> > update to grub2. I said OK - after the re boot I picked the chain option.
> > The boot went well, so I ran the update-from-grub-legacy script. Now I am
> > getting Grub 1.5 error and the boot goes nowhere.
> >
> >   
> I hate to say this, but you may have a problem. The usual answer to this 
> is to boot into some version of Debian, as you have done, then mount 
> your HD root partition and chroot into it. You can then run commands 
> which can hopefully rebuild the Grub system, or even reinstall it.

  I tried that but nothing seemed to work

> The bad news is that I tried that after the attempted update to Grub2, I 
> even tried booting the netinstall CD and installing Grub from there. I 
> even tried installing lilo.
> I suppose at some point, the updater will force the complete upgrade. By 
> that time, I assume that the netinstall image will install Grub2 from 
> scratch, so I'll backup and reinstall again. Just like Windows...

  Well as I said in earlier mail, the Supergrub disk saved my...err..bacon.
  It allowed me to reinstall Grub, then I purged Grub-pc (grub2) and was
back in business.
I still fail to understand what went wrong. After the installation and reboot
which went OK, I picked the chain option and that's  when it all went downhill.
My understanding is if the initial reboot goes well, then you pick the chain option
and that's supposed to finish up the install. Instead what it did was finish my 
boot process:) Obviously grub-pc is not ready for primetime yet. On the update it
did on my machine, it failed to pick up the Ubuntu installation on another partition.
How did it get migrated to Squeeze ?

- -- 
Version: GnuPG v1.4.9 (GNU/Linux)


Reply to: