[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: I can not set up postfix to send email through SSL-connection

Thank You for Your time and answer, Andrei, again:

> I'll post snippets out of my config and you can compare:
> ,----[ /etc/postfix/main.cf ]
> | # Enable authentication
> | smtp_sasl_auth_enable = yes

Same w/ me.

> | # The file that contains the passwords per user
> | smtp_sasl_password_maps = hash:/etc/postfix/sasl/sasl_passwd

I do not have it. But, I have the virtual users - that are in a
database - the accounts and passwords, therefore, I think I have to
specify it some other way. Have I?

> | # Other options
> | smtp_sasl_type = cyrus

Do not have too. From whence it came - I looked at man master - and did
not find it? Where do You look for the main.cf options?!
I tried it, restarted postfix - but the problem has not been solved.
So, for now I have removed it again (just for notice).

Again, no any records in /var/log/mail.log about a connection try.

Should I keep opened port 10025? or it is sufficient for 465? - When I
try to send letters w/ SSL - it connects only on 465 - according to
iptables reports.

> | # Is this still neded? Yes
> | smtp_sasl_security_options =
> `----

I have here:
smtpd_sasl_security_options = noanonymous

I think it is ok, is it?

> ,----[ /etc/postfix/sasl/sasl_passwd ]
> | [smtp.gmail.com]:587 andreimpopescu@gmail.com:MySecretPassword
> `----
> You also need to run 'postmap' (as root) on this file.

I have it not, as I have stated above.

> If I read this right you have libsasl2-2 and libsasl2-modules
> installed (status ii), which is ok.


Reply to: