[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: testing update today hosed aptitude!

Hash: SHA1

On 05/06/09 19:44, Patrick Wiseman wrote:
> On Wed, May 6, 2009 at 10:56 AM, Sven Joachim <svenjoac@gmx.de> wrote:
>> On 2009-05-06 16:40 +0200, Daniel Burrows wrote:
>>> On Wed, May 06, 2009 at 10:02:57AM -0400, Patrick Wiseman <pwiseman@gmail.com> was heard to say:
>>>> I did my daily testing update this morning, and aptitude has
>>>> disappeared.  Attempts to apt-get install aptitude are so far
>>>> unsuccessful, because of unmet dependencies.  Attempts to install
>>>> those missing dependencies also fail, in particular the following:
>>>> # apt-get install libapt-pkg-libc6.7-6-4.6
>>>   Which testing mirror are you using?  That version of apt should be in
>>> testing.
>> Alas, there has been an upload of apt to testing-security which broke
>> things, because that version of apt provides libapt-pkg-libc6.9-6-4.6
>> instead.  I've informed the testing security team about the situation,
>> CC'ing bug #448249 which is responsible for this.
>> Everyone suffering from this bug should downgrade apt to or,
>> even better, from stable-security.  Then aptitude,
>> synaptic and other reverse dependencies of libapt-pkg-libc6.7-6-4.6 can
>> be reinstalled.
> Tried that, but after downgrading, 'apt-get install aptitude' returns:
> # apt-get install aptitude
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
>   apt-utils: Depends: libapt-pkg-libc6.9-6-4.6
>   aptitude: Depends: libept0 (>= 0.5.26) but it is not going to be installed
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> specify a solution).
> In other words, apt-utils needs the apt version supplied by the latest
> apt package!  (I'm on an amd64 system, which may be the difference.)
> And 'apt-get -f install' just wants to re-upgrade the apt package I
> just downgraded.
> Patrick

IMHO, it looks as though you need to downgrade apt-utils. I may be
wrong, but it looks as though you need an older version of apt-utils
that corresponds with the version of libapt-pkg.

- -- 
Many thanks
Harry Rickards (a.k.a l33tmyst)

Version: 3.1
GAT/GCM/GCS/GCC/GIT/GM d? s: a? C++++ UL++++ P- L+++ E--- W+++ N o K+
w--- O- M- V- PS+  PE Y+ PGP++ t 5 X R tv-- b+++ DI D---- G e* h! !r y?
- ------END GEEK CODE BLOCK------
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org/


Reply to: