[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: testing update today hosed aptitude!

On 2009-05-06 20:44 +0200, Patrick Wiseman wrote:

> On Wed, May 6, 2009 at 10:56 AM, Sven Joachim <svenjoac@gmx.de> wrote:
>> Everyone suffering from this bug should downgrade apt to or,
>> even better, from stable-security.  Then aptitude,
>> synaptic and other reverse dependencies of libapt-pkg-libc6.7-6-4.6 can
>> be reinstalled.
> Tried that, but after downgrading, 'apt-get install aptitude' returns:
> # apt-get install aptitude
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> You might want to run `apt-get -f install' to correct these:
> The following packages have unmet dependencies:
>   apt-utils: Depends: libapt-pkg-libc6.9-6-4.6
>   aptitude: Depends: libept0 (>= 0.5.26) but it is not going to be installed
> E: Unmet dependencies. Try 'apt-get -f install' with no packages (or
> specify a solution).

Yes, you need to downgrade apt-utils as well.  And libapt-pkg-dev, if it
is installed.

> In other words, apt-utils needs the apt version supplied by the latest
> apt package!  (I'm on an amd64 system, which may be the difference.)
> And 'apt-get -f install' just wants to re-upgrade the apt package I
> just downgraded.

After the downgrade, put apt and apt-utils on hold to keep them from
being upgraded again.


Reply to: