[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Kerneloops & Intel 82541PI Gigabit Ethernet woes


A few months ago I ran into a problem where my Gigabit Ethernet card
would work perfectly under 32bit Lenny but had problems under 64bit
(details at end of post). I made mention of it and then found that
someone had already posted about the problem. 

I wanted to see if the problem had been fixed yet, so I just tried using
the card again recently with a fully updated Lenny install. Works
perfect with a 32bit lenny live CD, a 64bit Ubuntu live cd, but fails
with the 64bit installation of Lenny already on the machine. So I tried
looking for the bug report to no avail. I could have sworn I had found a
Debian bug report about it when I encountered this problem a few months
ago. However, I can't find that bug report anymore. What I think
happened is that it was merged with another bug report because I found a
few that are similar, but not with the same card I have. 


For the most part, the above link describes my problem, they just use a
different card / driver. It isn't exact but it is similar. They suggest
installing a newer kernel, which I did. I installed the 2.6.28-1 from
sid. Didn't fix my problem.

One of the side effects of the gigabit is that I get a kerneloops
message. So I sent it in hoping I could track down more info. However, I
can't seem to find where that information is stored locally (I have no
idea what was sent), and I couldn't find my exact problem searching on

So the questions I have are: Is the kerneloops information stored
locally? Is there a way to track down what you sent on kerneloops so you
can follow the progress? Does anyone have a better link for tracking
this problem then the one I have? I would really like to start using my
Gigabit network card again.


$ lspci | grep Intel
04:09.0 Ethernet controller: Intel Corporation 82541PI Gigabit Ethernet
Controller (rev 05)

/var/log/messages output when the network cable is plugged in.

/var/log/message output after updating to the kernel in sid.

Reply to: