[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Issues with PCF and BDF Fonts after regular lenny updates [SOLVED]

On Mon, 8 Dec 2008 23:36:39 +0100
Florian Kulzer <florian.kulzer+debian@icfo.es> wrote:

I apologize I did not follow with this for a while. I just got done

> I realized that on my system it is actually KDE that adds ~/.fonts to
> the font path when I log in. So it seems normal that it is missing from
> your font path since you do not use KDE. If you want, you can add
> xset fp+ ~/.fonts

I tried this but doesn't seem to make a difference.

> > I tried this but no luck with the Dina font.
> > 
> > $ fc-match Dina
> > Vera.ttf: "Bitstream Vera Sans" "Roman"
> Do you get any output from:
> grep -i dina ~/.fonts/fonts.*
amitu@debian:~$ grep -i dina /home/amitu/.fonts/fonts.*
-windows-dina-medium-i-normal--16-100-96-96-c-80-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_i400-8.bdf
-windows-dina-medium-i-normal--13-80-96-96-c-70-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_i400-9.bdf
-windows-dina-medium-i-normal--15-90-96-96-c-70-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_i700-10.bdf
-windows-dina-bold-i-normal--16-100-96-96-c-80-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_i700-8.bdf
-windows-dina-bold-i-normal--13-80-96-96-c-70-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_i700-9.bdf
-windows-dina-bold-i-normal--15-90-96-96-c-70-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_r400-10.bdf
-windows-dina-medium-r-normal--16-100-96-96-c-80-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_r400-8.bdf
-windows-dina-medium-r-normal--13-80-96-96-c-70-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_r400-9.bdf
-windows-dina-medium-r-normal--15-90-96-96-c-70-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_r700-10.bdf
-windows-dina-bold-r-normal--16-100-96-96-c-80-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_r700-8.bdf
-windows-dina-bold-r-normal--13-80-96-96-c-70-microsoft-cp1252 /home/amitu/.fonts/fonts.dir:Dina_r700-9.bdf
> Can I download the Dina font from somewhere to experiment myself?

I got it from here...


However, I got it solved by doing the following in my ~/.fonts dir:

$ mkfontdir; mkfontscale

Any ideas to why this worked?


Reply to: