[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: debian/unstable: iceweasel segmentation fault

On Sun, Jul 20, 2008 at 15:11:20 -0500, Kent West wrote:
> Kent West wrote:
>> Kent West wrote:
>>> Florian Kulzer wrote:
>>>> On Sun, Jul 20, 2008 at 08:22:38 -0500, Kent West wrote:
>>>>> Bruno Voigt wrote:
>>>>>> I'm currently not able to start iceweasel
>>>>>> ii  iceweasel                                   3.0.1-1         
>>>>>>                     lightweight web browser based on Mozilla
>>>>>> ii  iceweasel-gnome-support                     3.0.1-1         
>>>>>>                     Support for GNOME in Iceweasel
>>>>>> Same result as with 3.0~rc2-2 0:
>>>>>>  bruno@wks:~$ iceweasel
>>>>>> Segmentation fault


>>>>> I just updated a box yesterday and am seeing the same problem. I  
>>>>> haven't  had time to debug it yet, but one thing I noticed is 
>>>>> that when I run ldd  against /usr/bin/iceweasel, it dies also. 
>>>>> This leads me to believe the  problem is deeper than a mere 
>>>>> iceweasel problem.


>> westk@enjae:~$ sudo ldconfig -pNX | grep local
>> westk@enjae:~$ sudo /sbin/ldconfig -pNX | grep local
>> westk@enjae:~$
>> No output.

That looks OK; I was suspecting that you might have an outdated or
otherwise broken non-Debian library in /use/local/lib.

> New clue.
> I just discovered that "sudo iceweasel" works.

Maybe this will clear things up, then: Strace iceweasel again as your
normal user, like this:

strace -f iceweasel 2>iceweasel.strace

After it has crashed, grep for "EACCES" in the strace file; that should
tell you which files it cannot access due to permissions problems.

Regards,            | http://users.icfo.es/Florian.Kulzer
          Florian   |

Reply to: