[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Unmet dependencies Xfce4

Daniel Burrows wrote:
On Thu, Apr 24, 2008 at 07:06:15AM +0100, andy <geek_show@dsl.pipex.com> was heard to say:
Can someone please advise on the best way to handle the following situation of unmet dependencies:

$ sudo apt-get install xfce4-systemload-plugin xfce4-goodies
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
xfce4-systemload-plugin: Depends: libxfce4util-1 (>= 4.2.1-1) but it is not going to be installed Depends: libxfcegui4-3 (>= 4.2.1-1) but it is not going to be installed
E: Broken packages

  Have you tried resolving these explicitly?
apt-get install xfce4-systemload-plugin xfce4-goodies \
                    libxfce4util-1 libxfcegui4-3

  Did you check what version of each package is available and that the
versions satisfy the dependencies?  e.g., using something like this:

    apt-cache madison xfce4-systemload-plugin xfce4-goodies



I followed your suggestions. This is the output for running aptitude install xfce4-goodies:

$ sudo aptitude install xfce4-goodies
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
Reading task descriptions... Done
The following packages are BROKEN:
 libxfce4util4 libxfcegui4-4
The following NEW packages will be installed:
 hddtemp{a} libsensors4{a} libxfce4util-1{a} libxfcegui4-3{a}
 lm-sensors{a} mousepad{a} thunar-media-tags-plugin{a} xfce4-artwork{a}
 xfce4-battery-plugin{a} xfce4-clipman-plugin{a} xfce4-cpufreq-plugin{a}
 xfce4-cpugraph-plugin{a} xfce4-diskperf-plugin{a} xfce4-fsguard-plugin{a}
 xfce4-genmon-plugin{a} xfce4-goodies xfce4-mailwatch-plugin{a}
 xfce4-minicmd-plugin{a} xfce4-mount-plugin{a} xfce4-netload-plugin{a}
 xfce4-notes-plugin{a} xfce4-quicklauncher-plugin{a}
 xfce4-screenshooter-plugin{a} xfce4-sensors-plugin{a}
 xfce4-smartbookmark-plugin{a} xfce4-systemload-plugin{a}
 xfce4-verve-plugin{a} xfce4-wavelan-plugin{a} xfce4-weather-plugin{a}
0 packages upgraded, 29 newly installed, 0 to remove and 2 not upgraded.
Need to get 4046kB of archives. After unpacking 10.2MB will be used.
The following packages have unmet dependencies:
 libxfcegui4-4: Conflicts: libxfcegui4-3 but 4.2.2-1 is to be installed.
 libxfce4util4: Conflicts: libxfce4util-1 but 4.2.2-1 is to be installed.
Resolving dependencies...
The following actions will resolve these dependencies:

Install the following packages:
xfce4-systemload-plugin [0.4.2-1 (testing, testing)]

Keep the following packages at their current version:
libxfce4util-1 [Not Installed]
libxfcegui4-3 [Not Installed]

Score is 38

I've searched all over the place, but cannot find any reference to how I should interpret a score of 38. But given that there are still unmet dependencies and package conflicts, I am a little gun-shy to proceed without understanding more fully what will be the likely outcome, or a more sane workaround.

Any thoughts?




"If they can get you asking the wrong questions, they don't have to worry about the answers." - Thomas Pynchon, "Gravity's Rainbow"

Reply to: