[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: emacs sarge surprise!

On Wed, Apr 23, 2008 at 04:53:15AM -0500, Jude DaShiell <jdashiel@shellworld.net> was heard to say:
> Check this out, I downgrade to sarge which was the highest form of sarge  
> before everything moved along into etch and later lenny.  The aptitude  
> package was uninstalled and so I try repeating that operation where  
> bsdgames and emacs21 get installed together.  Emacs21 has aptitude as a  
> dependency and cannot install without aptitude being preinstalled and  
> happy.  If that problem never did get remedied (aptitude required to  
> install emacs) then there's no point in my taking any of this any 
> further. For one thing aptitude ought to be a pre-dependency of emacs and 
> apt-get didn't know about that and let me know either.

  Huh?  emacs doesn't depend on aptitude at all.  The strongest
relationship is a Suggests:

daniel@alpaca:~$ aptitude why emacs21 aptitude
i A emacs21            Depends  emacs21-bin-common (= 21.4a+1-5.3)     
i A emacs21-bin-common Depends  emacs21-common (= 21.4a+1-5.3)         
i A emacs21-common     Depends  dpkg (>= 1.9.0)                        
i A dpkg               Suggests apt                                    
i A apt                Suggests aptitude | synaptic | gnome-apt | wajig

  I don't know what version of Debian you're talking about, but I would
be aghast if any version of Emacs depended on any apt program (the dpkg
dependency is only there because dpkg contains install-info).


Reply to: