[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: apt-get -dist-upgrade leaves wireless keyboard and mouse useless on "sarge"



On Fri, Dec 28, 2007 at 09:31:40AM +0100, Sven Joachim <svenjoac@gmx.de> was heard to say:
> Hi,
> 
> On 2007-12-28 04:19 +0100, Daniel Burrows wrote:
> 
> > On Thu, Dec 27, 2007 at 11:26:00AM -0800, schmity <schmity@nctv.com> was heard to say:
> >> brent@Linuxbox:~$ uname -r
> >> 2.4.27-3-386
> >> brent@Linuxbox:~$
> >
> >   Ah.  Ok, you're running a very very old kernel (one that's not even
> > part of etch, let alone lenny) with up-to-date user-space software.  I
> > bet the problem is related to the hardware detection code, which
> > probably doesn't know about whatever old driver your kernel needs.
> >
> >   Could you try installing the latest kernel in lenny and see if it
> > helps?  I believe that would be linux-image-2.6.22-3-686 -- obviously
> > only if you have a 686+ chip (anything made in the last 5 years will be).
> 
> He's not running lenny, the libc6 there does not work at all with a 2.4
> kernel.

  And of course /etc/debian_version would say "lenny/sid" on lenny. Doh.

  In that case, I'm not sure *what* he's running, because he clearly has
testing in his sources.list.  I still think installing a 2.6 series
kernel is probably a good idea.

  Daniel


Reply to: