[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: mysterious loss of internet connection

On Wed, 7 Nov 2007 08:49:10 -0500, I wrote:
> My Etch machine at home is connected to a DSL service via a Netgear hub
> (router) at home.  Sometime in the last two days, the machine lost its
> network connection to the outside world.  It seems to be a software problem.
> ...
> I'd appreciate any suggestions on how to continue chasing this down.

On Wed, 07 Nov 2007 19:45:07 +0530, Raj Kiran Grandhi replied:

> What is the output of "route -n"?
> there should be an entry which looks like
> ..... eth0

As expected, I see

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface   U     0      0        0 vmnet8   U     0      0        0 eth0   U     0      0        0 vmnet1         UG    0      0        0 eth0

where is the router.  (I tried starting without vmware but it didn't

On Wed, 7 Nov 2007 10:04:53 -0500, Douglas A. Tutty wrote:

> Are you pinging by IP or DNS name?  Try by IP to remove the possibility
> of a DNS problem.  From a box that does work, ping debian.org and get
> the IP.  Then from the problem box, ping that IP and see if it goes
> through.  If it does, then its a DNS problem.

Neither ping succeeds.  I was a little surprised that I do still have name
resolution.  If I do "host debian.org", for example, it resolves to  (This is not coming from /etc/hosts.)

On Wed, 07 Nov 2007 15:24:58 +0100, Christian Jaeger <christian@jaeger.mine.nu>

> try "tcpdump -i eth0 -p -n" during pinging of outside adresses

I started the tcpdump command, then started "ping debian.org", and got the

  tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
  listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
  17:02:12.626080 IP >  41061+ A? debian.org. (28)
  17:02:12.638319 IP >  41061 1/3/0 A (105)
  17:02:12.638618 IP > ICMP echo request, id 58398, seq 1, length 64
  17:02:13.638421 IP > ICMP echo request, id 58398, seq 2, length 64
  [more of those]
  17:02:24.655745 IP > ICMP echo request, id 58398, seq 13, length 64
  17:02:25.018434 IP > RIPv1, Response, length: 44
  17:02:25.656605 IP > ICMP echo request, id 58398, seq 14, length 64
  [more of those]
  17:02:29.669048 IP > ICMP echo request, id 58398, seq 18, length 64
  17:02:30.657695 arp who-has tell
  17:02:30.658311 arp reply is-at 00:a0:c5:e2:b4:56
  17:02:30.669758 IP > ICMP echo request, id 58398, seq 19, length 64
  [more of the same; interrupt tcpdump with ^c]
  42 packets captured
  42 packets received by filter
  0 packets dropped by kernel

> if you can attach to the DSL directly

It may come to that, but it would involve lugging everything upstairs.  The
router lives next to my wife's XP machine.

Finally, on Wed, 7 Nov 2007 09:09:11 -0800 (PST), joseph lockhart wrote:

> i had a similar problem here, i run my internet through a cable connection,
> and had mysteriously lost the ability to connect to the internet. Probably a
> completely diffrent cause but i would check dbus i have found that it wants
> to shut itself off and ignores me everytime that i tell it to start running
> on startup (which i have set the last several times that i have booted up)

Sorry, but I don't know enough to understand this.  If you can describe what
steps you took to fix it (it you could at all),  I could try them.  I do show
these processes running:

  /usr/bin/dbus-daemon --system
  /sbin/dhclient -1 -lf /var/lib/dhcp3/dhclient.eth0.leases -pf /var/run/dhclient.eth0.pid -q -e dhc_dbus=31 -d eth0

Thanks to all of you.

Reply to: