[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: exim4/fetchmail/mutt problem

Kumar Appaiah wrote:
On Mon, Sep 03, 2007 at 08:26:19AM -0400, Thomas H. George wrote:
In ./usr/sbin exim is a symlink to exim4. exim is owned by root:root with 777 permissions. exim4 was owned by root:tom with 731 permissions. I changed the permissions to 777 but this did not correct the problem. I still got exim: permission denied when I executed mailq as user tom. mailq works for root.

OK, I meant su;mailq or sudo mailq.

You should be able to run mailq as root. Otherwise, you have a
problem. For me, it's just a symbolic link to /usr/sbin/exim4.

strace -e trace=open,write mailq run from user tom exits after

   open ("/etc/passwd
   write(2, "exim: permission denied

If I run /etc/init.d/exim4 restart I get a warning that the exim4 paniclog is not empty. tail/var/exim4/paniclog ends with "failed to read delivery status for tom@dragon.zoo from the delivery subprocess.

I have tried editing exim4.conf.template and uncommenting the Login lines in the Authentication section and entering my user name and password after the colons in the server_promts line. This does not solve the problem.


Reply to: