[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: [OT] gob.mx = IE6 only!

Florian Kulzer wrote:
On Mon, Jul 09, 2007 at 07:39:57 -0500, Hugo Vanwoerkom wrote:
Octavio Alvarez wrote:
On Sun, 08 Jul 2007 05:33:46 -0700, Hugo Vanwoerkom wrote:
Tried to register at this site:

Complete registration will only work for Mexican nationals because of the RFC and CURB entries.
That would be "CURP".
When you hit any of the buttons in iceweasel, seamonkey or konqueror nothing happens! Neither with user-agent switcher!

So this is an official Mexican government site *hardcoded* to M$ IE!

I am on Sid with iceweasel When I access the site with
javascript turned off (noscript extension) then I can use both the
"register" button and the "recover password" button. The register button
takes me to a page with an input mask for personal data and the password
button takes me to a page where I can enter my email address to have my
password mailed to me. That seems OK to me.

If I change my user agent string to "IE 6.0 WinXP" (using the prefbar
extension) and turn on javascript then the "enter" button starts to work
as well, as far as I can tell: If I leave the email and password fields
empty and press "enter" then I get a dialog telling me to fill in my
email and password. If I put in a bogus email address and password then
I am simply returned to the login screen after the server checks them.

Which version of iceweasel and which user agent string did you use?

I tried iceweasel ( I am behind in my Sid upgrade...) and user agent string "IE 6.0 WinXP".

However, non functionality of buttons only showed up *after* filling out of all the fields correctly. (The reason I mentioned the CURP and RFC fields)

Before that the appropriate dialogs kept appearing. Only after completing the form did the buttons do nothing in iceweasel and konqueror.

I did not try Opera.


Reply to: