[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

What's this error message telling me?

Here's what I get:

telly@ephome:~$ su
ephome:/home/telly# apt-get upgrade
Reading package lists... Done
Building dependency tree... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
3 not fully installed or removed.
Need to get 0B of archives.
After unpacking 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up slib (3a4-4) ...
/usr/bin/guile-1.6: error while loading shared libraries: libqthreads.so.12: cannot enable executable stack as shared object requires: Permission denied
dpkg: error processing slib (--configure):
subprocess post-installation script returned error exit status 127
dpkg: dependency problems prevent configuration of guile-1.6-slib:
guile-1.6-slib depends on slib (>= 3a2-3); however:
 Package slib is not configured yet.
dpkg: error processing guile-1.6-slib (--configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of g-wrap:
g-wrap depends on guile-1.6-slib; however:
 Package guile-1.6-slib is not configured yet.
dpkg: error processing g-wrap (--configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
E: Sub-process /usr/bin/dpkg returned an error code (1)

I tried to install slib, guile-1.6, guile-1.6-slib. I get the same error each time. I tried to install gnucash and that's how I first got this error. I can't even use openoffice (it won't run). The guile-1.6-libs won't install either.
What am I missing here?  ~Telly

Reply to: