[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian Install problems

On Mon, Apr 30, 2007 at 10:48:26PM -0700, Buzz wrote:
> I'm having some issues installing etch on a laptop running amd 64 x2.
> I used the i386 release 1st DVD iso.  The last time I touched linux
> was like 8 years ago.

Why did you choose i386 over amd64?  If all else fails, you may want to
try it.  If there are specific 32-bit apps you need, amd64 has the
32-bit libs available to run _most_ natively, otherwise you can run a

> I set up a couple partitions in vista (I realize this is not the best
> way to do it) to be used for the filesystem and swap area for a dual
> boot.  I manually configured the partitions using the installer, but I
> got an message while the installer was installing the packages about
> how the swap space was not active.

I don't know anything about sharing swap with vista since I haven't run
'doze since 3.1.

> On first boot, the GUI appeared to come up as a greyish background,
> but the grey graphic was changing to a charcoal color, with no
> progress.

I've never run the GUI installer.  The installation manual says that the
graphic installer isn't as full-featured as the newt(text) installer but
I don't know if the difference applies to you.  YMMV.

> When I try to boot into single user, it locks up.  Here is the last
> line:
> Checking TSC synchronization across 2 CPUs.
> CPU#0 had -543 usecs TSC skew, fixed it up.
> CPU#0 had 543 usecs TSC skew, fixed it up.
I've never had 2 cpus to play with :) so I don't know.

> ...so I booted from a rescue CD and checked the partition table for /
> dev/sda.  Here is a summary of each device:
> sda1 is the largest partition with the boot sector and vista, NTFS,
> ~95GB
> sda2 appears to be a hidden windows recovery partition, ~2GB
> sda3 is the linux filesystem which is supposed to mount at /  when
> booted, 10GB
> sda4 is another windows partition for recovery ~6GB
> sda5 is the swap partition "Linux Swap/Solaris" at 2GB
> I tried mkswap /dev/sda5 followed by swapon /dev/sda5 to no avail.

What where the specific errors?


> So, I guess I'm feeling pretty clueless here.

What did fsck on the linux partitions show?

> FWIW, I was able to install using the same DVD image on an older
> laptop (only linux--no dual boot) with no problems.

You may want to remove the linux partitions from vista and leave them as
free space on the drive.  Then use the installer to create them.  Also,
disk space is cheap, don't share swap.

You may consider getting the amd64 netinst.iso and try that.

Good luck,


Reply to: