[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Strange aptitude problem

On Tue, May 01, 2007 at 08:33:27AM +0000, Andy Hawkins wrote:
> Hi all,
> My box automatically runs aptitude overnight to update the packages list,
> and download any packages that need upgrading. It doesn't install them, I'd
> rather do that myself.
> However, it's now doing this:
> gently:~# aptitude -f dist-upgrade
[snip normal aptitude output]
> The following packages are BROKEN:
>   php4-mysql
> The following packages are unused and will be REMOVED:
>   php4-cli
> 0 packages upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
> Need to get 0B of archives. After unpacking 3166kB will be freed.
> The following packages have unmet dependencies:
>   php4-mysql: Depends: phpapi-20050606+lfs which is a virtual package.
> Resolving dependencies...
> *** Uncaught exception in resolver thread:
> Unexpectedly non-broken dependency php4-mysql 6:4.4.4-8+etch2 ->
> {libapache-mod-php4 6:4.4.4-8+etch1 libapache2-mod-php4 6:4.4.4-8+etch1
> php4-cgi 6:4.4.4-8+etch1 php4-cli 6:4.4.4-8+etch1}!
>   (php4-cli 6:4.4.4-8+etch1 is installed)
> Anyone got any ideas? Is this something broken my end, or a broken package?

Fire up aptitude interactively (no command line arguments) and see
what's up.


Reply to: