[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: some fonts in kde / iceweasel not anti-aliased - but not all




"Adam Hardy" <adam.ant@cyberspaceroad.com> wrote in message 462D3DA2.60805@cyberspaceroad.com">news:462D3DA2.60805@cyberspaceroad.com...
Florian Kulzer on 23/04/07 20:40, wrote:
On Mon, Apr 23, 2007 at 20:04:58 +0100, Adam Hardy wrote:
Got a wierd problem that I can't find any viable solution for in google. I set up a new machine with etch, running kde and iceweasel.

Most of the main fonts are not anti-aliased in iceweasel. I downloaded firefox and tried that, same result.

The funny thing is that I am running etch on another machine and I upgraded everything to the same level, but it's not affected.

Does anyone else here know what the problem could be?

Compare the fontconfig settings on the two machines, for example by
running this command on each system:

awk '/fontconfig/,/^$/' /var/cache/debconf/config.dat

My guess is that the "enable_bitmaps" setting is responsible. You can
change all the settings by running "dpkg-reconfigure fontconfig-config".
(Restart X after that to be sure.)

By the way, this would be a xorg thing, would it? Rather than KDE, gnome or xfce etc?

Well it is general to X yes (rather than specific to some windowing environment). But in fact fontconfig can be used by other apps. Indeed fontconfig is likely being used because your system is using Xft for fonts. If a different mechanism were in use for fonts, then that change would likely have had no effect. (I'm pretty sure Xft is the default on Debian, but am not 100% positive on that).



Reply to: