[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Sound on Linux?

Raffaele Morelli wrote:

1. Try kill artsd deamon if running...
2. from a root shell /etc/alsa reload
2. lsmod | grep snd, so you are sure that snd modules are loaded
4. cat /dev/urandom > /dev/audio   do you hear something? (white noise)
5. if you got xine installed (dvd video player) try a DVD, if sound doesn't work properly DVD's audio track is "piped" to a wav file ( xine-out.wav or similar). A simple test but I think it's worth to try

Here is the return from lines 1, 1st 2 and 2nd 2 above:

LAP:~# artsd stop
Link points to "/tmp/ksocket-root"
can't create mcop directory
LAP:~# /etc/alsa reload
-su: /etc/alsa: is a directory
LAP:~# lsmod|grep snd
snd_opl3_synth         13924  0
snd_seq_instr           7392  1 snd_opl3_synth
snd_seq_midi_emul       5952  1 snd_opl3_synth
snd_ainstr_fm           2496  1 snd_opl3_synth
snd_opl3sa2            19148  0
snd_opl3_lib            9920  2 snd_opl3_synth,snd_opl3sa2
snd_hwdep               8836  1 snd_opl3_lib
snd_cs4231_lib         23232  1 snd_opl3sa2
snd_pcm_oss            38368  0
snd_mixer_oss          15200  1 snd_pcm_oss
snd_pcm                68676  2 snd_cs4231_lib,snd_pcm_oss
snd_page_alloc          9640  2 snd_cs4231_lib,snd_pcm
snd_mpu401_uart         8064  1 snd_opl3sa2
snd_seq_dummy           3844  0
snd_seq_oss            28768  0
snd_seq_midi            8192  0
snd_seq_midi_event      7008  2 snd_seq_oss,snd_seq_midi
snd_seq 45680 9 snd_opl3_synth,snd_seq_instr,snd_seq_midi_emul,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              20996  4 snd_opl3_lib,snd_cs4231_lib,snd_pcm,snd_seq
snd_rawmidi            22560  2 snd_mpu401_uart,snd_seq_midi
snd_seq_device 7820 7 snd_opl3_synth,snd_opl3_lib,snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq,snd_rawmidi snd 47012 14 snd_opl3_synth,snd_opl3sa2,snd_opl3_lib,snd_hwdep,snd_cs4231_lib,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_mpu401_uart,snd_seq_oss,snd_seq,snd_timer,snd_rawmidi,snd_seq_device
soundcore               9248  1 snd

No. 4: "LAP:~# cat /dev/urandom > /dev/audio" definitely gave me white noise.

As for no. 5, I *think* what I have in the laptop is a CD-ROM drive only. Regardless, I would not know how to differentiate a CD-ROM drive from a DVD-ROM drive. The only external marking on the drive is the word "disc" in large tip, with the word "compact" in small type over the "isc" of the word "disc".

    I find that strange, as the the CDROM drive was empty, nor could I see
    any application open, except icedove and a terminal emulator.

Maybe audio device it's busy 'cause artsd it's locking it


ps: did you googled around for your 'sound card + kernel support'

Alsamixer identified the integrated sound card and chip as a Yamaha OPL3-SA23. Earlier, when I ran alsaconf, first all the snd modules were removed. Second, alsaconf found a card labeled "oplsa2 snd-oplsa2", followed by "legacy Probe legacy ISA (non PnP) chips".

After selecting "OK" I was next presented with the following:

Configuring snd-opl3sa2
Do you want to modify /etc/modprobe.d/sound (and /etc/modprobe.conf if present)?

I answered "Yes".

Next it said:

OK, sound driver is configured.

ALSA  CONFIGURATOR will prepare the card for playing now.

Now I will load the ALSA sound driver and use amixer to raise the default volumes.

You can change the volume later via a mixer.

After clicking "OK" once again, alsa told me the following:

Running update-modules...

Loading driver...
Setting default volumes...


 Now ALSA is ready to use.
 For adjustment of volumes, use your favorite mixer.

 Have a lot of fun!

As the return from "lsmod|grep snd" above seems to indicate, alsaconf was as good as its word, having apparently installing all sorts of modules unique to this card.

I did get the white noise as described above, and I do get through the attached speakers some at least of the usual sounds which accompany various actions, such as completion of a user log on, and a beep when in a terminal I hit the down arrow key but there are no more commands in that direction to show.

I googled this card and found information which was for the most part way over my head but did tell me that this card is an ISA card and needs to be tweaked to work. One of the web pages returned from the Google search was part of the alsa howto: http://www.alsa-project.org/alsa-doc/alsa-howto/x1298.htm.

It nevertheless appears to me that alsaconf did all the tweaking necessary, as I have got some sound, but cannot play audio CDs or get newscasts.

Another factor may or may not be relevant. Two days ago I compiled from source and installed dosemu-1.3.4. The installation was successful in that it is allowing me to use my beloved dos based applications. However, the last message returned by ./configure was a warning that SDL version 1.2.0 was not found.

I consequently installed four packages which had sdl in the name: libsdl1.2debian, libsdl1.2debian-alsa, libsdl-net1.2 and libsdl-sound1.2. I tried to purge these packages, but aptitude wanted to remove a whole series of other packages including grub and icedove. So I did not remove them. I also tried to remove them using Kpackage, but Kpackage wanted to remove all of kde. So these four sdl packages remain installed. (Why do aptitude and Kpackage want to remove different apparent dependencies?)

If these packages are screwing up the sound, then a little knowledge on my part is dangerous. I should have asked whether that warning message could safely be ignored. Since I do not use the sound properties of dosemu perhaps I should have left well enough alone.


				Ken Heard

Reply to: