[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: konqueror is slow

On Tue, 2007-02-27 at 14:01 -0800, Andrew Sackville-West wrote:
> On Tue, Feb 27, 2007 at 01:15:39PM -0800, Michael M. wrote:
> > On Tue, 2007-02-27 at 11:33 +0100, Cédric Lucantis wrote:
> > > Hi,
> > > 
> > > > Hi all.
> > > >
> > > > On my laptop, konqueror takes, sometimes, tens seconds to access pages.
> > > > Since character terminal 'links' web browser quickly navigates across the
> > > > internet, network setting should be ok.
> > > > Any hints?
> > > > What to check for mis-configuration?
> > > 
> > > I add the same problem and two things helped me a lot:
> > > 
> > > - add the following in your /etc/environment (create the file if you don't 
> > > have one) : KDE_NO_IPV6=TRUE
> > 
> > So links doesn't use IPV6 by default?  I had to completely disable IPV6
> > to get anywhere with Debian (same with Ubuntu).  There's something funky
> > about the way (at least some) Debian-based distros handle IPV6.
> > 
> With all due respect to your situation, this seems pretty rare. I
> can't remember it coming up on this list, which is not to say it
> hasn't. Are you using IPv6 in some other fashion that might cause it
> to be a problem for konquerer? It certainly doesn't seem to be a
> problem for the general debian population.

Well I'm not really using IPv6 at all.  I disabled it.  My ISP doesn't
use IPv6.  When it was enabled, everything IPv6-aware that used http://
would time-out, most of the time.  This was some months ago and at that
time Konquerer was not IPv6-aware, so it worked fine.  But I'm not a KDE
user, so that didn't really help me much.  Besides, I got awfully tired
of having to ping everything first in order to get a connection.  I
couldn't even issue an 'aptitude update' without first pinging the
mirror -- 90% of the time it would time out before connecting.
Likewise, the only way I could load a website in w3m was by using the
no-IPv6 option; if I didn't specify that option, it would time-out and
the website wouldn't load.  Firefox and Thunderbird were also unusable,
until I disabled IPv6 for each in "about:config."

I had no trouble with IPv6-aware apps on my iMac, which was connected to
the same router.  At that time I was using Debian or Ubuntu PPC on my
iMac (dual-booting), and everything -- including Firefox and Thunderbird
-- just worked under OS X, but did not under Debian or Ubuntu.  Then I
tried Gentoo PPC on my iMac, and that worked fine too (no IPv6 issues).
Then I got a PC, which came with Ubuntu pre-installed, and the problem
was back.  Same with Debian after I installed it on this PC.  Meanwhile,
Arch Linux, which I also had installed on this PC, had no IPv6 issues,
and the same for FreeBSD.  The only fix I could find for Debian was
disabling IPv6 altogether.

So that's why I think it's a problem specific to Debian (and probably
those distros based on Debian).  Do you know different?

Michael M. ++ Portland, OR ++ USA
"No live organism can continue for long to exist sanely under conditions
of absolute reality; even larks and katydids are supposed, by some, to
dream." --S. Jackson

Reply to: