[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Detection of Hardware and Devices

Michael Pobega wrote:
john gennard wrote:

I have a problem getting sound to work in a Sarge install,
which is the subject of another thread. Having little
technical savvy, I often find things confusing or impossible
to comprehend.

If possible, I'd like someone to help me here. Sarge gives
the problem and Kubuntu (Debian based) works fine.

When I run '#lspci' on each I get the following results:-

1. Debian:
   0000:80:01:0    0403 Via Technologies, Inc. :
       Unknown device 3288 (rev 10)

2. Kubuntu:
   80:01:0   Audio Device: Via Technologies, Inc.
       Via High Definition Audio Controller (rev 10)

Alsaconf doesn't 'see' the device in Sarge which could well
be my problem. Why, though, does 'lspci' give such differing
results - I assume each run gets its information from the
same source (the device/chip itself).

Furthermore, my Motherboard Manual says the Audio is 'Realtek
ALC888 7.1 Channel audio CODEC with High Definition audio'.
Have Via used a Realtek chip and 'bundled' it with something of
its own?

My main aim is to get audio to work without getting a separate
card, but I'd like to have some light shed on this confusion
(in my simple mind that is!).


Have you tried Debian Etch? I know Debian Sarge is a bit older and has
much worse hardware detection than Etch. When I used Sarge nothing
worked for me, but an upgrade to Etch fixed everything. I'm not 100%
sure if just changing your sources.list and running # apt-get update &&
apt-get dist-upgrade would work though. I'd do a clean reinstall if

I've got Sarge working without problem on three other boxes, in
fact I maintain that Debian is the reason I never significantly
increase my technical knowledge - it never freeezes or even
breaks down so by the time a new release comes out I've long lost
what little knowledge I had acquired.

I had intended to go to Etch shortly (and by upgrade). I've plenty
of space on this hard disk, so I might as well install Etch from
scratch alongside Sarge and see if I get the success you did.


Reply to: