[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: old hardware, newer Debian

> s. keeling <keeling@spots.ab.ca> said:
> Mike McClain <mike.mcclain@nowhere.net>:
> >  I just installed sarge on a box I've happily been running woody on
> >  for 5 years and find I can't run X cause the Trident tvga 9800b
> >  chipset is no longer supported in the xserver-xfree86 v4.3. Any
> Try the svga driver.  I'm using a PCI Matrox card, development of
> which was stopped long ago.  svga driver picked up the slack and it
> works beautifully.

    Pardon the typo, the board is a Trident tvga 8900b, sometimes my 
fingers seem lisdexic.

    I've tried 'dpkg-reconfigure xserver-xfree86' with many different
    I've tried xf86config, xf86config and xdebconfigurator.
I've started over and done a full re-install on another partition,
thinking my minimul install might have missed something critical.

    Not once have I seen a chance to select svga. 
Vga and vesa yes but not svga. 

    Can you tell me what package gives you that functionality?
My board predates vesa hence doesn't answer properly and I get a black
screen, that's the case with the latest install now and it's booting 
into xfree86-common so it's hosed until I can fix it. In this my
original deb31 installation I've got vga 320x200 (the default) which
gives me video in only the lower half the screen and the taskbar is 
about 1 1/2" high and the mouse pointer 1" long.
    I've hand edited /etc/X11/XF86Config-4:
        Driver          "svga"
(EE) Failed to load module "svga" (module does not exist, 0)
I've also added mode lines copied from my woody install to no avail.

    If you're truly in svga mode but don't know which package is 
responsible, please post the output of:
    dpkg --get-selections | cut  -f1 | grep "^x"
maybe that'll give me a clue.

Thanks for your response,

Reply to: