[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Debian testing, alsa and cups



Hello.

Been thru the (RT)FM and maybe missed it but didn't find it.

Upgraded stable to testing, and it worked with much difficulty and repeated 'aptitude dist-upgrade' and ended up with two mildly annoying situations
with ALSA and CUPS.

ALSA won't provide sound after a reboot or re-logon unless I run the /etc/init.d/alsa-utils restart script. Works good after that. Using KDE3.5
and kernel 2.6.18.  Works OK with GNOME logon so it seems it's a
KDE thing. Could just run the command somewhere but I'd like to find
the problem, eventually.

CUPS also won't print after a logon or restart. I found this problem but I'm at a loss to fix it permanently. Seems the /dev/usb/lp0 device is assigned the user:group of root:lp instead of what CUPS likes, lp:sys. I can script this change too but same as above, I'd like to find the glitch and do it right. Does CUPS need to assign different permissions, or does the hotplug/udev
system need to assign a different user:group?  And where to do this?

Thanks for the assistance?

--

-----------------
tony
tjm3@threedogs.net



Reply to: