[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Debian testing, alsa and cups

tony mollica wrote:

Been thru the (RT)FM and maybe missed it but didn't find it.

Upgraded stable to testing, and it worked with much difficulty and repeated
'aptitude dist-upgrade' and ended up with two mildly annoying situations
with ALSA and CUPS.

You can save trouble upgrading from Sarge to Etch by following the five steps at http://newbiedoc.berlios.de/wiki/Aptitude_-_using_together_with_Synaptic_and_Apt-get#Upgrading_from_Sarge_to_Etch
(adapted from http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=401317).

ALSA won't provide sound after a reboot or re-logon unless I run the
/etc/init.d/alsa-utils restart script. Works good after that. Using KDE3.5
and kernel 2.6.18.  Works OK with GNOME logon so it seems it's a
KDE thing.  Could just run the command somewhere but I'd like to find
the problem, eventually.

Following Etch, I occasionally find that Alsa appears not to work. I think the problem lies with occasional changes to the autodetect software which configures my motherboard's integrated sound and ignores the PCI card. Easily fixed by running alsaconf.


Reply to: