[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sarge->etch upgrade hits dependency hell

On Tue, Dec 12, 2006 at 11:54:24AM -0500, hendrik@topoi.pooq.com wrote:
> On Mon, Dec 11, 2006 at 10:27:29AM -0800, Andrew Sackville-West wrote:
> > On Mon, Dec 11, 2006 at 08:57:03AM -0500, hendrik@topoi.pooq.com wrote:
> > > On Sun, Dec 10, 2006 at 07:38:37PM -0800, Andrew Sackville-West wrote:
> > > > 
> > > > why don't you boot sarge, chroot into etch and install a kernel from
> > > > inside the chroot? I think udev wants a kernel >= 2.6.15, IIRC.
> > > 
> > > Actually, it turns out that aptitude *&had* managed to install the new 
> > > kernel -- it just hadn't put it into the boot menu -- a probelm easily 
> > > fixed from the sarge system.
> > 
> > great!
> > 
> > > 
> > > I now have an etch with networking, which I can use aptitude on, but 
> > > whose X doesn't come up properly.  startx brings me to the black screen 
> > > of death, xdm permits me to enter username and password, blanks the 
> > > screen as if it is doing something, and then returns to its login 
> > > screen.  gdm doesn't even get to login -- it just gives the black screen 
> > > of death.
> > > 
> > > I looks as if I will have to investigate another day -- my regular users 
> > > are showing up.
> > 
> > one step at a time eh? of course you nkow the drill, post the X logs.
> > 
> > good luck
> I made no changes since my remarks quoted above.  But when I booted this 
> morning, X did come up, XDM gave me a login window, and it allowed me 
> to log in and have access to my usual home directory.  But it did give 
> me gnome instead of icewm (which was my default under gdm).

well, that's weird.

> So I now know that X works, that it recognises the screen, the keyboard, 
> the mouse, and so forth.


> When I switched to the text-mode console using ctl-alt-F1, it gave me 
> that, and it worked properly too.
> But all was not well.  When I switched back (using ctl-alt-F7) it gave 
> me a scrambled screen -- lots of horizontal streaks.  The various 
> window decorations were present, but in multiple copies, and each 
> mostly obscured by the horizontal bars.  Evidently the screen size in 
> its frame buffer did not match the screen size it was using.

sounds like a driver issue for sure.

> I could ctl-alt-F1 back to the text cosole, which worked, and kill a 
> carefully chosen process, and return to the X screen to be greeted by 
> another login window, which worked too.

hmmm.... which process did you kill? also, try killing xdm and then
using startx and see if that gives you the same problems above when
switching consoles.

> sing gdm instead of xdm still gives the black screen of death instead of 
> a login window.

weird that gdm fails and xdm doesn't. Have you gone down the road of
purging all of X and reinstalling it? 

> Also -- is it suspicious that there were no package updates in etch this 
> morning?

nope. I haven't check my cron-apt output today for my one etch
machine, but that doesn't surprise me.  I think with etch freeziong,
you will only see bug fixes from now on which will probably make the
updates minimal.


Attachment: signature.asc
Description: Digital signature

Reply to: