[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: sarge->etch upgrade hits dependency hell

On Fri, Dec 08, 2006 at 10:30:43AM -0800, Andrew Sackville-West wrote:
> On Fri, Dec 08, 2006 at 11:40:27AM -0500, hendrik@topoi.pooq.com wrote:
> > 
> > I tried that, and got a *huge* raft of proposed deletions -- just from 
> > asking for aptitude to be upgraded.
> what did you use to upgrade aptitude? you might want to use something
> that thinks its less intelligent to do this. If you used aptitude to
> try and upgrade aptitude, maybe you could try apt-get or even manually
> with dpkg. 
> this all assumes you tried it with aptitude. Aptitude (not starting a
> war here folks) will try to be too smart sometimes in working through
> the dependencies resulting in a huge pile of deletions.

I wouldn't say "too smart".  I'd say not smart enough.  It's smart 
enough to come up with a set of consistent package versions, but not 
smart enough to come up with a reasonable set.  I did find, for example, 
that a lot of the packages that were to be deleted because they depended 
on other packages were actually quite savagable -- I just '+'ed then and 
they suddenly had no such dependency difficulties -- suggesting to me 
that aptitude should have been able to discover that itself.

> so maybe
> apt-get or dpkg would work to get that one out of the way and then you
> could move on to upgrading the rest. or, if you
> wnted to use aptitude, you could try and figure out which "groups" of
> packages it was trying to remove and work up the dependency tree and
> mark the major ones to keep or hold.

The logjam broke when I deleted the xfractint package -- this was 
undicated by the presence of an xfractint file within /use/X11R6/bin.

> For example, if for some reason
> that aptitude upgrade tries to delete all of X, go in and manually
> select xorg and give it a + (instlal) or : (hold) and that should
> cascade down to the whole x system and keep it. 

Except I also had to convert from xfree to xorg and pass the 
/usr/X11R6/bin hurdle that came in with the xorg6.9->7.0 upgrade.
I think it just got to be too much for aptitude.
> I haven't read the whole thread in detail so I'm sorry if I'm
> repeating stuff here. 
> my apt-cache show's that aptitude only depends on a handful of other
> packages (including, of course libc6, the big one). what is your
> apt-cache policy for aptitude -- specifically the depends line. and
> what versions of those packages do you currently have installed?

I've done *nothing* special in apt-cache -- it is just the way Debian 
installed it, unless Debian itself modified it.
> A

Unfortunately, after the mass upgrade yesterday, the system now boots 
without either a functioning X or a functioning net.  udev complains 
that it doesn't have a recent enough kernel, which may be part of the 
problem (no /dev/eth*, for example).  So the next step seems to be to 
find out how to tell my apt-sources file to look at an etch-install 
CDROM (will the netinstall CD suffice for this, or do I actually have to 
get the first CD of the 15-odd CD set?) as a package-source and then 
upgrade the kernel.

-- hendrik

Reply to: