[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Odd Gnome behavior

On Tue, 2006-12-05 at 23:14 +0100, Sven Arvidsson wrote:
> On Tue, 2006-12-05 at 13:41 -0800, Freddy Freeloader wrote:
> > If I run any of the tools found in the Desktop -> Administration menu, 
> > explicitly from that menu, Gnome asks me for the root password.  I enter 
> > the root password and it tells me I entered an invalid password.  
> > However, if I run any of those same admin tools from the Applications -> 
> > Debian -> Apps -> System menu Gnome accepts the root password and they 
> > run just fine.  
> > 
> > Does anyone know what is going on with this?  I do the vast majority of 
> > my work from the bash prompt, but on occasion I will want to just look 
> > at a setting and will choose to do that from the gui tools.  Although 
> > this problem is easily worked around I'm stumped as to why this is 
> > happening. 
> > 
> > BTW, this behavior started when I changed the behavior of sudo from the 
> > Debian default of not requiring a password to requiring one.  I've since 
> > reversed that to see if that is responsible for the change in behavior 
> > in the gui, but it has made no difference whatsoever. 
> > 
> > Any clues as to where to look would be appreciated. 
> Hi,
> g-s-t, when launched from the gnome menu, uses gksu for authorisation,
> when launched from the debian menu, it uses something built in, i think.
> gksu can be configured via gconf-editor.

Thanks for answering, but I'd already tried this.  The settings on my
desktop, where the problem exists, are no different than the settings on
laptop, where everything works normally.

I also realize that I haven't explained the problem in great enough
detail. What happens is if it's the first time I try during a session to
use one of the admin tools it will first ask for the password to the
keyring. After I give it the screen will clear for a fraction of a
second, and the app will show up behind a second request for root's
password.  That request for a password is always returned as an invalid
password.  I have tried the keyring password, my password, and root's
password.  All are denied.

If I configure gsku to use sudo-mode I will be asked for root's password
twice, and the second time it asks for it the password will be

Reply to: