[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Odd Gnome behavior

On Tue, 2006-12-05 at 13:41 -0800, Freddy Freeloader wrote:
> If I run any of the tools found in the Desktop -> Administration menu, 
> explicitly from that menu, Gnome asks me for the root password.  I enter 
> the root password and it tells me I entered an invalid password.  
> However, if I run any of those same admin tools from the Applications -> 
> Debian -> Apps -> System menu Gnome accepts the root password and they 
> run just fine.  
> Does anyone know what is going on with this?  I do the vast majority of 
> my work from the bash prompt, but on occasion I will want to just look 
> at a setting and will choose to do that from the gui tools.  Although 
> this problem is easily worked around I'm stumped as to why this is 
> happening. 
> BTW, this behavior started when I changed the behavior of sudo from the 
> Debian default of not requiring a password to requiring one.  I've since 
> reversed that to see if that is responsible for the change in behavior 
> in the gui, but it has made no difference whatsoever. 
> Any clues as to where to look would be appreciated. 


g-s-t, when launched from the gnome menu, uses gksu for authorisation,
when launched from the debian menu, it uses something built in, i think.

gksu can be configured via gconf-editor.

Sven Arvidsson
PGP Key ID 760BDD22

Attachment: signature.asc
Description: This is a digitally signed message part

Reply to: