[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: rhythmbox

Hans van Middendorp on 04/07/06 19:38, wrote:
On Tue, 04 Jul 2006 07:20:36 +0100
Adam Hardy <adam.ant@cyberspaceroad.com> wrote:
Hans van Middendorp on 02/07/06 21:28, wrote:
On Sun, 02 Jul 2006 15:48:20 +0100
Adam Hardy <adam.ant@cyberspaceroad.com> wrote:
Thomas Jollans on 02/07/06 15:05, wrote:
Adam Hardy wrote:
Just did a general upgrade in etch and accepted all bugs and have
problems now with rhythmbox, which won't play any MP3s now. it'll
play OGG files, but not MP3s.
Trying to fix it, I came across some directions for testing files
with gstreamer, and I realise that rhythmbox considers itself a
Gnome app, but I'm using KDE. I don't have gstreamer installer,
it looks like a heavy-weight Gnome component, maybe even a
daemon but I'm not sure. So to test, I should install gstreamer,
but I'm not convinced I need gstreamer at all in KDE. But
perhaps rhythmbox has changed now to work only under Gnome.

Anyone know what the situation is?
GStreamer is a library that is used heavily in Gnome, but does not
use a daemon by default. (unlike arts...) It does not hurt to
install gstreamer and gstreamer should not depend on anything
rhythmbox didn't depend on anyway... (like glib etc)
Sorry Thomas, meant to send that to the list.
I installed gstreamer but I don't have the command 'basicgthread'
which it seems I need to run from the cmd line to test play my

I tried running rhythmbox under gnome and but that made no

So what is gstreamer or more to the point, how do I get rhythmbox
to use it, if even that is what the MP3 problem is all about?

I am not sure if Rhythmbox is using gstreamer0.8 or already 0.10.
If 0.8 it will play mp3 with gstreamer-mad. After installing that
run gst-register-0.8 in console as normal user.

If 0.10 i thimk you need gstreamer-0.10-fluendo-mp3. The gst
command is not necassary voor v0.10.

I no go, give quod-libet a try.
quod-libet didn't work either:
"Gstreamer encountered a general stream error."

There is obviously something wrong with the config because gst-launch
works OK.

When i was using Rhythmbox with Gnome 2.12 i had some problems to get it
running. In Gnome, as far as i can remember, i had to put the
sound(daemon or systen) on gstreamer, esd or alsa. Cannot remenber
which one. With Gnome 2.14 it is put on "automatic" by default.

Now, i am using Xfce4 with alsa. Rhythmbox and Quod Libet are both
working well.
Maybe you could install a light windowmanger like Fluxbox or Icewm and
see if they will run from there. But be sure that no sound daemons from
KDE or Gnome are running.
I think the problem is somewhere in the soundsystem/daemons.

I ran rhythmbox in fluxbox and got the following processes, which gives me a strong impression that gnome is still controlling something here:

adam     24088 24069 28 13:12 ?        00:00:26 /usr/bin/rhythmbox
adam     24091     1  0 13:12 ?        00:00:00 /usr/lib/libgconf2-4/gconfd-2 11
adam     24093     1  0 13:12 ?        00:00:00 /usr/lib/bonobo-activation/bonobo-activation-server --ac-activate --ior-output-fd=15
adam     24096     1  0 13:12 ?        00:00:00 /usr/lib/gnome-vfs-2.0/gnome-vfs-daemon --oaf-activate -iid=OAFIID:GNOME_VFS_Daemon_Factory --oaf-ior-fd=23
adam     24123     1  0 13:13 ?        00:00:00 /usr/bin/rhythmbox

What surprises me is that esd and artsd are both missing, yet under KDE I see them in the ps list all the time. So what do I have to do here? How can I decouple gstreamer from gnome?
Or is it impossible (I'm suspicious of the g on the front of gstreamer).


ps I tried xfwm4 but it doesn't support my monitor running with RandR (yet - perhaps it'll come).

Reply to: