[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Mouse an 2.6 Kernel Problems: Solved

A while back I posted that I had some problems with my mouse and a 2.6 
kernel.  At first, I had problems with early 2.6 kernels, even with 
Ubuntu's live CD, as well as Sarge.  The mouse would jerk all over the 
place whenever I tried to move it anywhere.  Then I started using Sid 
and overall it worked, but I had a problem with the scroll wheel.  
There was no problem scrolling down, but whenever I scrolled up in 
Firefox, as soon as I moved the mouse after scrolling up, it acted like 
I was highlighting the text.  If I scrolled up in KMail in a list 
window, the item under the mouse was selected as soon as the scroll 
wheel moved up.

Nobody had a solution and I searched quite a bit until I found something 
not too reliable (I can't even remember what it was!) suggesting the 
KVM.  I've been using Linksys 4 port KVM for several years -- so much 
so that I forget I have it -- even when I switch from one computer to 
another, I tend to take it for granted because the hotkeys worked well 
and I hadn't touched the KVM in several years.  I never realized it was 
so easy to forget about a piece of hardware.  I had never had even a 
hint of trouble from the KVM before, but I tested the connections and 
plugged the mouse into the computer without the KVM and had no trouble 
at all.  (I had also asked here for comments on KVMs before buying a 
new one.)

My mouse problem is fixed and it only cost about $90.  I bought a new 
KVM switch from Egghead.  I've only had this one up and running for a 
short time and I'm having a hard time adapting to things working right.  
No more scroll wheel problem at all.  It's amazing how you get used to 
work arounds and avoiding certain actions!  Unfortunately, as hard as  
I searched, I never found a software solution to this problem.  I tried 
using different input devices, but that didn't help.

I had tried a number of fixes and config changes to get things working 
and nothing helped with the old KVM.  Then I plugged in the new KVM and 
the mouse went nuts.  I'd move it a little bit and it would jump and 
jerk all over the screen like mad and bring up context menus, jump from 
one window to the one behind it (how it did that I'll never know, since 
both windows were maximized!) and other flakey stuff.  Then I 
remembered what I just stated here: I still had fixes in place for the 
old problem -- fixes that weren't working.  So I edited my xorg.config 
file and changed the mouse device to /dev/psaux, since it's a PS/2 
mouse and restarted X.  No help.  So I went into /etc/modules and 
commented out mousedev so it wouldn't be used and commented out the 
line mouseproto=raw and rebooted.

That was all it took and it is now working quite well.  I can scroll up 
and down through a list window and that first movement up on the scroll 
wheel no longer selects an item.  I can scroll up and down in a web 
page or other page of text in different programs and starting to scroll 
up no longer starts selecting text.

For the record, I bought an IOGear GCS78 8 port KVM.  I had been using a 
Linksys 4 port KVM for 4-5 years with no problem until I started using 
a 2.6 kernel.  Even then, I'm so used to the KVM that it's become 
transparent and, even though I use it to switch from box to box, I 
forget about it.  When I first tried a 2.6 kernel I had serious 
problems with the mouse jumping around (like it did today, when I first 
tried the new switch before rebooting) and stuck with the 2.4 kernel 
until I tried the 2.6.15 in Sid.  Since the KVM had always worked so 
well and had become transparent to me, I didn't suspect it until just 

There are only 2 points on the new KVM that I am not thrilled about: 1) 
It needs a power supply, and the Linksys did not, and 2) The Linksys 
used ctrl-alt-shift-x-enter as hotkeys, where "x" was the number of the 
computer you were switching to.  It wasn't picky, so I could press down 
the first 4 keys together, let up, and press enter and it would switch.  
This switch uses ctrl-shift-alt-x-enter and is much pickier.  I can't 
press any of the keys simultaneously: I have to press them all in 
sequence or it won't switch.  It takes about half a second longer to do 
that.  Maybe I'm just being picky.

I seriously looked at KVMs with much faster switch times and with on 
screen display, but decided there was no reason to shell out the extra 
money.  This is a good KVM and I can even gang it with others to 
control upto something like 256 computers with one keyboard, mouse, and 

While, at this time, I'm only using 4 ports, now I can hook up my 
firewall and be able to access it if, for some reason, ssh isn't 
working and I have some extra ports for expansion.

If anyone is having similar problems, I don't think you'll get them 
fixed without replacing the KVM.

If anyone is considering a KVM, this one seems solid, but, hey, I've 
only been using it 15 minutes.

I hope this helps someone out there so they don't go through several 
months of mouse problems like I did before finding a solution.


Reply to: