[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: k3b is not able to detect dvd+rw-tools package

On Wednesday 01 February 2006 11:13, kamaraju kusumanchi wrote:
> Justin Guerin wrote:
> >On Tuesday 31 January 2006 21:23, kamaraju kusumanchi wrote:
> >Have you tried it as a non-root user?
> Forgot to mention this. k3b works fine for ordinary users. Only when I
> use it through sudo, it gives the above error.
> >I tried running k3b as root, using kdesu, and it worked fine for me.
> kdesu k3b is also working fine (without any errors). The problem is
> occurring only when k3b is run under sudo.
> thanks for the reply
> raju
The problem is in the environment active when you start k3b.  Check your 
environment variables after a sudo (i.e. sudo env), and after a kdesu env.  
Kdesu sets up your environment to look more like your present environment, 
and that's why it works.  Somewhere, in the difference between the two, is 
your problem.  I'd check your path first.


Reply to: