[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: logrotate + mysql = "Help!"

Jay Zach wrote:
> Eric d'Alibut wrote:
>>I have a Debian stable install that runs smoothly; uptime is seventy
>>three days. Just lately I am getting these system emails:
>>error: error running shared postrotate script for /var/log/mysql.log
>>/var/log/mysql/mysql.log /var/log/mysql.err /var/log/mysql/mysql.err
>>run-parts: /etc/cron.daily/logrotate exited with return code 1
>>I am clueless as to how to debug this error. I am, in fact, a mysql
>>moron. Any input would be appreciated!
>>No no no, my fish's name is Eric, Eric the fish. He's an halibut. I am
>>not a looney! Why should I be tarred with the epithet looney merely
>>because I have a pet halibut?
> Eric,
> I've had this same error over the last few days.  I believe that there are
> binary transaction logs in the /var/log/mysql directory not recognized by mysql.
>  Here's how I've fixed it (I'm not SQL guru either, so this probably isn't "by
> the book"):
> 1) I backed up my databases
> 2) I made a directory called /var/log/mysql/logbackup
> 3) I stopped mysql (/etc/init.d/mysql stop)
> 4) I moved all binary logs to the logbackup directory
> 	HOSTNAME:/var/log/mysql# mv *bin* logbackup/
> 5) I restarted mysql (/etc/init.d/mysql start)
> 6) I manually ran the cron job to make sure it did not error
> This seems to have done it.  After a day or two, when I'm sure, I'll delete the
> logbackup dir I made....
> Good Luck :)
ummmmm............... n/m I had a different error, I meant to reply to an older
post by someone else who had the same error...
Sorry for the mixup and getting your hopes up....  Still, who knows, maybe it'll
work ;)

Here is the error I was receiving:

ERROR at line 1: Target log not found in binlog index
run-parts: /etc/cron.daily/mysql-server exited with return code 1


Don't everyone thank me at once!
		-- Han Solo

Tuesday Jan 10, 2006


Reply to: