[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: kernel has null dereference during boot

On Tue, Dec 13, 2005 at 02:39:11PM -0500, Marty wrote:
> hendrik@topoi.pooq.com wrote:
> >OOPS.  Forgot to identify the kernel.
> >
> >This problem occurs with kernels
> >	2.4.18-1-386
> >	2.4.18-1-586tsc
> >With kernel 2.2.20 I get the complaint about the invalid number of
> >physical heads, but not the crash.
> >
> >It used to work properly before I did the forced reinstall (The machine
> >was rooted)  When it worked, I believe I was using kernel 2.4.16-586.
> I would be suspicious that something tried to change the bootloader (e.g. 
> LILO or GRUB) or the partition table (MBR) on the drive, in a possible 
> (though unlikely) effort to defeat the cleanup attempt.
> First I would save copies of the partition table and bootloader for future 
> forensic purposes.

Too late!  I'll try and remember that next time.  By the way, how *do*
you save copies of the partition table and bootloader?

> Then I would try the fdisk "p" (print partition table) command to see if it 
> indicates anything wrong with the partition table.  I would also run LILO 
> on the drive with the -v -v -v -t options to see if it finds anything wrong 
> (or run the equivalent grub diagnostic).  If there are any remaining doubts 
> I would follow up with an appropriate disk editor to examine the drive more 
> closely.
> After locating and identifying any problem(s), I would rewrite the MBR 
> and/or bootloader.

I installed using SBM to boot off of the woody CD.  The installer
formatted a new swap partition, and a new boot/root partition, and
installed into that one.  The installer's lilo was used to rewrite
the MBR.  That should pretty well finish off the MBR,  no"

fdisk's "p" comment (the one in the installer did not notice anything
wrong.  Thanks for telling me about lilo -v -v -v.  I'll try that next.

-- hendrik

Reply to: