[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: ndiswrapper kernel panic



On Fri, Oct 28, 2005 at 01:46:23PM -0500, Ganeshram Iyer wrote:
> On 10/28/05, L.V.Gandhi <lvgandhi@gmail.com> wrote:
> > On 10/26/05, Ganeshram Iyer <ganeshramiyer@gmail.com> wrote:
> >
> > > there is another on this wiki (specific to sarge but it needs
> > > compilation - so did not try it).
> > can I get the url?
> >
> > > And as ndiswrapper.sf.net for this card says using a preemptive kernel
> > How to know kernel is preemptive?
> > What are the pros and cons of it?
> > I have compiled 2.6.13.4 from kernel.org with oldconfig of 2.6.8.2.
> > Now how to make ndiswrapper work with this kernel. I can't install
> > ndiswrapper utils package as it asks for package for old kernel as
> > dependency? Is there any tutorial/how to go about with new kernel in
> > sarge?
> as for Sarge installation the wiki is here:
> http://ndiswrapper.sourceforge.net/mediawiki/index.php/InstallDebianSarge
> while the one i used was:
> http://ndiswrapper.sourceforge.net/mediawiki/index.php/InstallDebian
> I do not know how to find if the kernel is preemptive. I hope someone
> who has answers can help me out but for now i am not using this card
> with debian (at least not regularly).

To check if your kernel is preemtive, simply do something like this:

$ grep PREEMPT /boot/config-2.6.8-miami-16
CONFIG_PREEMPT=y

Of course, you will need to substitute your actual kernel version.  If
it says `n' then you don't have a preemptive kernel.

-Roberto

-- 
Roberto C. Sanchez
http://familiasanchez.net/~roberto

Attachment: pgpZbly3qDq2O.pgp
Description: PGP signature


Reply to: