[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: embedding fonts

Thanks for the info.  I did fix the problem, sort of.  I found that 
passing the -Pdownload35 option to dvips causes the fonts to be 
embedded.  (LyX uses dvips as part of the process of generating the 
PDFs; the preferences dialog has a way to specify adding options like 
that.)  I'm kind of unclear what that option does, though - the package 
docs don't mention it, and I found lots of references to it online, but 
no definition.

I am using the Qt/fontconfig version. I'd still like to know why fonts 
suddenly stopped embedding.  I may not realistically have time to track 
it down - since it works now (insert image of software being held 
together by duct tape :), and there are a lot of other things needing 
my attention.  If I figure it out soon I'll post a followup.

Thanks again for the help :)

Aaron Maxwell - http://redsymbol.net
Skills for higher math - http://InnerAlgebra.com
COMING SOON: Retail Worker's Survival Guide - http://rwsg.us

On Tuesday 20 September 2005 03:14 pm, Almut Behrens wrote:
> On Tue, Sep 20, 2005 at 01:39:48AM -0700, Aaron Maxwell wrote:
> > Hi, I'm running testing.  I am having trouble with creating PDFs
> > with embedded fonts.  (I'm generating them from LyX and LaTeX
> > sources.)  The process worked before an apt-upgrade I did a week
> > ago.
> >
> > I'm still investigating; I think it's an issue with ghostscript, or
> > perhaps dvips or ps2pdf.  In the meantime, has anyone else had this
> > problem?  If so please post about it - the extra data points will
> > help. Thanks.
> >
> > PS:  When I start the LyX editor, I get the following error
> > messages. Clues!  Based on them, can anyone suggest what may be
> > good for me to look at?
> >
> > | jashenki% lyx ia-lulu-print.lyx
> > | xset:  bad font path element (#70), possible causes are:
> > |     Directory does not exist or has wrong permissions
> > |     Directory missing fonts.dir
> > |     Incorrect font server address or syntax
> > | Unable to add font path.
> This error message might in fact be related to the problem of fonts
> not being embedded...
> Upon startup, lyx is trying to issue an "xset fp+ FONTPATH" command
> to make sure the X server can access the TeX fonts (Type1 versions).
> As xset is complaining, apparently something is wrong with that
> FONTPATH, e.g. invalid path specification, doesn't exist, doesn't
> contain 'fonts.dir', whatever... (IIRC, TeX's Type1 fonts should be
> in /usr/share/texmf/fonts/type1/public/*/*.pfb -- not sure though).
> I suspect that those are the same fonts which are supposed to be
> embedded in the PS/PDF output (via ghostscript), so it's probably a
> good idea to check whether they're installed properly.
> BTW, are you getting any errors from ghostscript?
> You could run "lyx -dbg font ..." to get more verbose debugging info
> on font handling.  Among other things this should print something
> like "Adding FONTPATH to the font path".  Then commence your bug
> chase by trying to figure out what's wrong with FONTPATH ;)
> In case you're using the Qt frontend with Xft2 and fontconfig (to
> check, look for libfontconfig.so in the output of running 'ldd' on
> the lyx binary), things are somewhat different.  I believe you need
> to have some other package installed (latex-xft-fonts ?), though I'm
> not sure in what way that could be related to your font embedding
> problem. I'm afraid any ramblings of mine won't be of much help in
> that case, as I haven't fully grokked fontconfig myself, yet :)
> Also, I currently don't have lyx installed, so this is all a bit
> vague... but good luck anyway,
> Almut

Reply to: