[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

RE: unable to install from CD: failure to mount once kernel installed

> From: Wackojacko [mailto:wackojacko32@ntlworld.com]
> Sent: Friday, September 23, 2005 5:56 AM


> Googling this error (google is always your friend :) ) suggested that
> - you may want to turn DMA off for the drive ' hdparm -d0 /dev/hdc'.
> May need to install 'hdparm' first.

Ah, thanks for both the suggestion and the method.  Mike McCarty privately
suggested that I disable DMA for this drive, but I couldn't do it from BIOS
and was unaware of this system utility.  Thank you very much for bearing
with me.  This seems to fix the problem!  It also uncovered another minor
bug, but at least the system is usable.

After disabling DMA on the CDROM, inserting a CD causes the file system to
mount, a CD icon to appear on the gnome desktop and a Nautilus file browser
opens showing the CD file system.  To unmount the file system and unlock the
CDROM eject button, close the file browser, right click on the CD desktop
icon and hit eject.  At that point, I get an error dialog that reports:
Failed to start command (details: Failed to execute child process "eject"
(No such file or directory)).  However, the CD icon does then disappear from
the desktop and the CDROM tray eject button becomes unlocked, so it did the
job despite the error message.  Directly unmounting the CD file system as
root using umount /media/cdrom0 accomplishes the task without any error
messages, though you shouldn't have to do this.  So it appears that I have
two bugs to report, one for the driver not being able to operate the drive
with DMA enabled and another for the GUI error, though I am not certain what
packages to report them under.

Googling a bit further, as you suggested, shows that failure to mount CD's
is not a new problem in Linux and some people have unsuccessfully tried to
fix the root causes.  I hope they are still trying.  See
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=137831  This user had
the same problem with both FC3 and FC4 and with certain builds, the problem
was intermittent.  Follow-up reports showed that it was a nasty interaction
between haldaemon, DMA and the kernel itself.  It was not fixed in the
2.6.12-1.1398_FC4 kernel, though they expected it to be.  The root cause is
thought to be some piece of code looking for information at the very end of
a CD that is at a different location when the CD is not completely full.
The DMA hangs waiting for the nonexistent data and things go downhill from
there.  The Fedora crew still hasn't solved this one, suggesting it is more
complicated than that.  I haven't figured out if it is limited to Joliet,
Rock Ridge or plain ISO9660.  The media I used were all Joliet and I don't
believe that I have any other types around to try.  Both CD writers that I
own are on Windows machines, and they always write with Joliet format

I would like to report the fact that the CDROM driver malfunctions with DMA
enabled to the Debian bug tracker, and the eject GUI error as a separate
bug, but I'm not sure what packages to list.  After reading the Fedora
discussion on this problem, it's not clear that anyone really knows which
packages are at fault.

I also wonder how to make this change permanent.  I could put a call to
hdparm in one of the init scripts, though I was hoping that /etc/fstab or
some other configuration file might have a "nodma" option to set for that
drive.  I cannot find such an option in either the Debian reference or the
man pages for fstab, mount, etc.  I'm sure it exists somewhere, but I
haven't been able to find it.  The Debian reference shows a command called
setcd in section 9.1.3, but it looks like it's meant for setting the default
speed.  The package page on setcd has no information on what it does.

> - hal (hardware extraction layer) deamon can cause this trouble so try
> stopping haldeamon if installed.

I didn't try this, but I bet it would work.  It's not as good a workaround,
though, as you would want to start it again each time you were done reading
a CD.


Seth Goodman

Reply to: