[Date Prev][Date Next] [Thread Prev][Thread Next] [Date Index] [Thread Index]

Re: Qlogic Fibre Channel Controller


On Mon, 19 Sep 2005 13:59:59 -0700 Nick <n@wyzo.net> wrote:
> Cameron Matheson wrote:
> > I am in the process of doing this myself (same card).  I had to 
> > compile my kernel, but only because it seems that the debian kernel 
> > has removed the qla2300 module (could someone explain to me why?).  If 
> > you use the vanilla 2.6 sources though it will include the necessary 
> > kernel module.
> >
> So which drivers did you use? I cannot seem to find suitable driver 
> sources, Could you assist? and what stept did you have to go through to 
> get them installed and working at boot time?

Ok, I am using a module named 'qla2300'.  I did build my own kernel, and made sure to choose the 'CONFIG_SCSI_QLA2300=m' and 'CONFIG_SCSI_QLA2XXX=m' options.  Upon rebooting the hotplug stuff saw the cards and loaded the module for me.  Here's what the output should look like if all goes well:

qla2300 0000:02:0a.0: Found an ISP2312, irq 225, iobase 0xf88f8000
scsi5 : qla2xxx
qla2300 0000:02:0a.0: Configuring PCI space...
qla2300 0000:02:0a.0: Configure NVRAM parameters...
qla2300 0000:02:0a.0: Verifying loaded RISC code...
qla2300 0000:02:0a.0: Waiting for LIP to complete...
qla2300 0000:02:0a.0: LOOP UP detected (2 Gbps).
qla2300 0000:02:0a.0: Topology - (F_Port), Host Loop address 0xffff
qla2300 0000:02:0a.0: 
 QLogic Fibre Channel HBA Driver: 8.00.02b5-k
  QLogic QLA2340 - 133MHz PCI-X to 2Gb FC, Single Channel
  ISP2312: PCI (33 MHz) @ 0000:02:0a.0 hdma-, host#=5, fw=3.03.08 IPX

> Here is the procedure to rescan and add devices under linux per Qlogic :
> To force a rescan from the command line, type the following command:
> # echo "scsi-qlascan" > /proc/scsi/<driver-name>/<adapter-id>
> (QLogic driver rescans)

I tried this:
# echo "scsi-qlascan" > /proc/scsi/qla2xxx/1           
-bash: /proc/scsi/qla2xxx/1: No such file or directory

I'm assuming this is because the qla2xxx directory does not exist (nor does any other qla<blah> directory)... so i tried creating it manually:

cmatheson@godzilla:~$ sudo mkdir /proc/scsi/qla2xxx                             
mkdir: cannot create directory `/proc/scsi/qla2xxx': No such file or directory

maybe i'm not allowed to play around in /proc like that?  any tips?

Cameron Matheson

Reply to: